RunRyder RC
 50  Topic Subscribe
WATCH
 14 pages [ <<    <     11      12     ( 13 )     14     NEXT    >> ] 46080 views POST REPLY
HomeAircraftHelicopter
e-
Align
Other › HowTo: Align Swashplate fix
02-12-2006 04:03 AM  12 years agoPost 241
AceHelis

rrVeteran

Georgetown, Texas

My Posts: All  Forum  Topic

Please help!!!
I decided to do the "fix" from this thread and my swash did seperate easily with only finger pressure. But I was able to push from underneath with my thumbs and it came part way out and then when I pulled from the top inner swash the inner swash seperated from the part that came out of the outer swash. I have a pic of this at this site

scottmilton.shutterfly.com

look under "swash plate".
can I just use the procedure talked about here for this as well?

PM  EMAIL  GALLERY  Attn:RR  Quote
02-12-2006 04:13 AM  12 years agoPost 242
ShellDude

rrElite Veteran

East Coventry, PA

My Posts: All  Forum  Topic

Man, am I flirting with disaster or what?!?!?! My V2 hybrid swash is in need of some serious loving. I've been checking it ever since reading this thread and I seriously have to stop procrastinating.

Used my plyers tonight to get lined back up. The outer race was a good 3-4mm above its bearing. Thank Gawd I've been restricted to the basement lately as this thing would surely spin loose if I took it out for some serious flying.

I wonder what would happen if I complained to Andy. Think he'd hook me up with one of those new fancy Align stamped ones -- non eCCPM of course?

Shell

PM  EMAIL  GALLERY  Attn:RR  Quote
02-12-2006 09:36 AM  12 years agoPost 243
Yug

rrMaster

UK. Herts

My Posts: All  Forum  Topic

ACE1 - holy cow thats bad luck. Go buy another one, OR send that one back, OR, rough up surfaces and epoxy/CA/RED back together. (carefully)

PM  EMAIL  GALLERY  Attn:RR  Quote
02-12-2006 12:05 PM  12 years agoPost 244
smokingtommy

rrApprentice

east sussex ,england

My Posts: All  Forum  Topic

hi i have looked at mine and it a se swash in the manual it says new but it did not have the ALIGN on the side of it i tryed to pop it apart but could not i did not use a tool i just pushed with hand do you think mine will be ok ?

PM  EMAIL  GALLERY  Attn:RR  Quote
02-12-2006 12:18 PM  12 years agoPost 245
Professor Fate

rrKey Veteran

Goose Creek S.C.

My Posts: All  Forum  Topic

Quick UK
I sent Quick UK an E-Mail about if they had given any thought on producing swashs for these little buggers. Their reply.
Quick UK:
"We are not currently looking at the T-rex as an upgrade possibility. It may be something we consider in the future."
Just an idea. Hey it worked for Micro Heli.

Welcome my son, Welcome to the machine

PM  EMAIL  GALLERY  Attn:RR  Quote
02-14-2006 03:45 AM  12 years agoPost 246
Ozydego

rrKey Veteran

Westerville, Ohio

My Posts: All  Forum  Topic

Tommy, if you tried with the socket and could not get it apart, then you should be ok, post a detailed pic of the underside of your swash so we can see if we can tell if it is in fact the fixed swash...

Ace1, I could not get the webpage to load. Tomorrow is monday and that means free uploading to your gallery... please post the pic there so we can see what exactly happened. If I am reading right, it almost sounds like the bearing that seperates the upper silver swash from the lower blue swash came off of both sides... If this is the case you just fix it like you would the upper swash, clean the old glue off and sparingly glue the bearing back in to the lower swash, then glue the upper swash in like you normally would. A pic would really help, I will try the link again tomorrow to see if I can see the pic...

But Honey, I can't live with just stock.....

PM  EMAIL  GALLERY  Attn:RR  Quote
02-18-2006 06:19 PM  12 years agoPost 247
PanX

rrApprentice

Athens , Greece

My Posts: All  Forum  Topic

ok.. just another plastic one separated (CDE).. 3 pieces.. 120$ overall damage

Panos, SV1COX
http://users.forthnet.gr/ath/pbog/

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-20-2006 04:49 PM  12 years agoPost 248
cadwarrior

rrVeteran

Canada

My Posts: All  Forum  Topic

the provided anaerobic green retainer with the SE kit, works great to "re-glue" the swashplate, really strong!

PM  EMAIL  Attn:RR  Quote
02-23-2006 11:48 PM  12 years agoPost 249
007

rrApprentice

WHEELING WV

My Posts: All  Forum  Topic

stock plastic swash
does the stock plastic swash need fixed and can you fix it? Ron

PM  EMAIL  GALLERY  Attn:RR  Quote
02-23-2006 11:52 PM  12 years agoPost 250
Professor Fate

rrKey Veteran

Goose Creek S.C.

My Posts: All  Forum  Topic

If it's the V2 unit(gray plastic), you are probably ok. I never had a problem with mine and it went through H3LL.

Welcome my son, Welcome to the machine

PM  EMAIL  GALLERY  Attn:RR  Quote
02-24-2006 01:15 AM  12 years agoPost 251
Ozydego

rrKey Veteran

Westerville, Ohio

My Posts: All  Forum  Topic

I would check all swashes with the socket method. with the sE swashes, it gets complicated, but I would check and fix any older swash.,.. at least check it with the socket...

But Honey, I can't live with just stock.....

PM  EMAIL  GALLERY  Attn:RR  Quote
02-24-2006 08:37 PM  12 years agoPost 252
abormor

rrNovice

Gandia, Valencia, Spain

My Posts: All  Forum  Topic

I didnt fix mine...

PM  EMAIL  GALLERY  Attn:RR  Quote
02-28-2006 04:26 PM  12 years agoPost 253
Ozydego

rrKey Veteran

Westerville, Ohio

My Posts: All  Forum  Topic

that looks almost exactly like the helidirect swash I use.

Clearfortakeoff, this thread is for those that would like to have a workable unit without having to buy something extra....

But Honey, I can't live with just stock.....

PM  EMAIL  GALLERY  Attn:RR  Quote
02-28-2006 11:29 PM  12 years agoPost 254
ShellDude

rrElite Veteran

East Coventry, PA

My Posts: All  Forum  Topic

heh... i think that's cause it is Ozy

http://www.helidirect.com/images/im...450-UGT05V2.jpg

PM  EMAIL  GALLERY  Attn:RR  Quote
03-01-2006 01:48 AM  12 years agoPost 255
Ozydego

rrKey Veteran

Westerville, Ohio

My Posts: All  Forum  Topic

Not busted the thread, but mention on about page 3... of what 7 now?? Getting an aftermarket swash is definitely an acceptable solution, but fixing what we already have was the target of ths thread... I do appreciate the info though... FWIW, I really like my helidirect swash. I had to get it to work with my rotorworkz g3 frame, as the newest align swash doesnt have the 4th pin mount on the lower swash....

But Honey, I can't live with just stock.....

PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2006 01:58 PM  12 years agoPost 256
thomasf

rrNovice

San Leandro,CA USA

My Posts: All  Forum  Topic

I just bought a swashplate (grey) and tried to separate it by heating it up and using the socket, I banged on it pretty hard and could NOT separate it. I guess only time will tell now.

PM  EMAIL  Attn:RR  Quote
03-02-2006 08:59 PM  12 years agoPost 257
euknowho

rrApprentice

Flint, Michigan

My Posts: All  Forum  Topic

I was hoping beyond alll hope that it was only (mostly) the ECCPM swash that had this little problem. However, today after flying thie thing for about 4 months or so, ,,,,you guessed it,, MY mechanical mix swash gave up its "oneness" and as a result, I now need new tail blades, and langing gear struts.. Thankfully I was just getting it off the ground when it seperated!!! Oh well LIVE AND LEARN,, I should've done the FIX instead of just hoping for the best!!!

PM  EMAIL  Attn:RR  Quote
03-04-2006 05:45 PM  12 years agoPost 258
ShellDude

rrElite Veteran

East Coventry, PA

My Posts: All  Forum  Topic

OK Ozy, I'm about to throw in the towel. I took my hybrid swash off my T-Rex. It was obvious the only thing holding it together was the inner ball links.

So I tried using loctite adhesive (green), let it cure a couple hours, then applied a little bit of pressure and *pop*, off it went.

I then went the CA route and used some ZAP. Let it cure about 2 hours and then applied a little puressure... and *pop*, off it went again.

Last ditch effort was to use Red loctite. Let it cure overnight and came down this morning and applied a little pressure.... you guessed it... *pop*.

The flipside is that I've got the aluminum Microheli swash on order... may even be here today, but as far as I'm concerned these hybrid swashes are complete junk.

To add insult to injury Andy won't answer my emails after I pointed out that I had two doing the same thing (one not even installed). As far as I'm concerned Align owes me $44.90

PISSED LIKE A MOFO,
Shell

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2006 06:59 PM  12 years agoPost 259
MikeInMobile

rrElite Veteran

Mobile, Alabama

My Posts: All  Forum  Topic

If the swash that you were trying to bond has plastic on it, locktite will not work properly. You need to roughen up the metal slightly to give the metal some bite for the adhesive. Then, you can use either Plasti-zap (ca made for plastics), or a slow setting epoxy for the bond .... either will bond it permamently.

Locktite only works when both parts are metal and the clearance between the parts is extremely small (tight fitting parts). Regular CA will not bond properly to plastics that contain ANY nylon (the plastic used by Align does contain nylon).

PM  EMAIL  GALLERY  Attn:RR  Quote
03-04-2006 07:04 PM  12 years agoPost 260
ShellDude

rrElite Veteran

East Coventry, PA

My Posts: All  Forum  Topic

Thanks Mike,

I quickly ran this through my common english translator.
Locktite only works when both parts are metal and the clearance between the parts is extremely small (tight fitting parts). Regular CA will not bond properly to plastics that contain ANY nylon (the plastic used by Align does contain nylon).
Here's what I got:
You're screwed

<edit>

I really don't know why this one activity annoys me so much. I spend countless hours tinkering with my helicopters.

I took your advice and dremeled both the inside of the plastic outer plate and the side of the inner metal ring. Mixed up a small batch of 30 minute epoxy and have it curing.

I'll give it 12 hours or so to fully cure then try the "pop" test again.

</edit>

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 14 pages [ <<    <     11      12     ( 13 )     14     NEXT    >> ] 46080 views POST REPLY
HomeAircraftHelicopter
e-
Align
Other › HowTo: Align Swashplate fix
 Print TOPIC  Make Suggestion 

 50  Topic Subscribe

Monday, June 25 - 8:49 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online