RunRyder RC
WATCH
 1 page 500 views POST REPLY
Home✈️Aircraft🚁HelicopterHelicopter Main Discussion › Strange glitches?
11-12-2005 10:39 PM  14 years ago
Topic Vote0Post 1
Quick50Nikl

rrApprentice

Sweden,Sthlm,järfä lla,

MyPosts All Forum Topic
Strange glitches?
I just bought a Hornet 2 with a Jeti mini 7ch resiver, it says single conversion on it so i guess i need single conv crystals, but i couldnt find any single conv for the TX so i put a single conv in resiver and a ordinary FM crystal in my TX.

As i turn heli on it seem fine for about 10min then it looses signal and the servos goes CRAZY,

I use a Hitec Eclipse 7ch,

Both Re Tx are 35mhz,

Dont know , do i need to find single conv crystals for Tx ??
or is this brobaly outside interference coz it only shows sime times.just keeps me thinking ive got the wrong crystals.

Any help would be nice,
Assumption is the mother of all . . . . ups
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
11-13-2005 12:02 AM  14 years ago
TAZZY

rrVeteran

Westfield,MA

MyPosts All Forum Topic
i would use dual conversion receiver and use the dual conversion crystal.
Single conversion sucks
GDay
SHARE  PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
11-13-2005 12:32 AM  14 years ago
dkshema

rrMaster

Cedar Rapids, IA

MyPosts All Forum Topic
Hey sparky -- put your original TX crystal back in. There is no such animal as a dual conversion TRANSMITTER crystal. The transmitter isn't the problem here, your receiver is.

You need the CORRECT crystal for your receiver, one that matches your transmitter's frequency, and one that actually works in THAT receiver. With receivers, not just ANY crystal will do. If the RX is a single conversion, you need to get the single conversion crystal on the correct frequency that will work in the Jeti receiver.

Once you get the right crystal in the RX, you'll probably need to switch your transmitter to PPM if you have it set for PCM mode. Otherwise, you'll still have trouble.

Dave
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
11-13-2005 03:21 PM  14 years ago
Quick50Nikl

rrApprentice

Sweden,Sthlm,järfä lla,

MyPosts All Forum Topic
Thx but ive done that crystal numbers match, single conv in RE fm same requency in TX.

This is what happens, Iturn it on motor is not connected, servos work as they should for 3min-1hour then suddenly it freaks out. i pull the cord wait for 1min turn it on imediatly it freaks, turn it off wait for 10min then its ok for like 10min it varies, it also starts sometimes as i unplug and plug battery in.

could my reciver be dameged and work sometimes, or if a RE is broke its broke?
Assumption is the mother of all . . . . ups
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
11-13-2005 06:54 PM  14 years ago
dkshema

rrMaster

Cedar Rapids, IA

MyPosts All Forum Topic
Plug a normal receiver battery pack into the RX, eliminate the speed controller and battery eliminator as a possible cause. See what happens then.

Dave
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
11-13-2005 11:05 PM  14 years ago
Quick50Nikl

rrApprentice

Sweden,Sthlm,järfä lla,

MyPosts All Forum Topic
Thx for ur help.


located the problem prob reciver Iam getting another one same brand but updated with MPD, less interference. With matching brand crystal.

hope it helps
Assumption is the mother of all . . . . ups
SHARE  PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 500 views POST REPLY
Home✈️Aircraft🚁HelicopterHelicopter Main Discussion › Strange glitches?
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Friday, July 10 - 10:59 am - Copyright © 2000-2020 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online