RunRyder RC
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 1016 views POST REPLY
HomeAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › need glitch help
11-10-2005 02:04 AM  12 years agoPost 21
planesarenofun

rrApprentice

Ahwatukee, az

My Posts: All  Forum  Topic

i tried moving the antenna around and running it different ways... no change

PM  EMAIL  GALLERY  Attn:RR  Quote
11-10-2005 09:17 AM  12 years agoPost 22
jkelly

rrVeteran

Bedford, PA

My Posts: All  Forum  Topic

Did you check the gears for the tail?

PM  EMAIL  GALLERY  Attn:RR  Quote
11-10-2005 12:34 PM  12 years agoPost 23
planesarenofun

rrApprentice

Ahwatukee, az

My Posts: All  Forum  Topic

it does it when the heli isnt running

PM  EMAIL  GALLERY  Attn:RR  Quote
11-14-2005 11:06 AM  12 years agoPost 24
jkelly

rrVeteran

Bedford, PA

My Posts: All  Forum  Topic

That's what I'm saying. I had the same problem in a different heli when the gears were worn. It glitched while sitting on the counter in my kitchen. I don't know if that is your problem but something to consider. Also a hairline crack in a metal part maybe? I remember having a glitch a long time ago caused by a loose screw on the boom support on a plastic raptor but the support ends were metal.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 1016 views POST REPLY
HomeAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › need glitch help
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, July 16 - 4:07 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online