RunRyder RC
WATCH
 1 page 723 views POST REPLY
HomeAircraftHelicopter
e-
Mikado
Other › Logo 14 - Weird head wobble (right and left)
10-16-2005 06:46 PM  12 years agoPost 1
LoopZilla

rrNovice

Melbourne, FL

My Posts: All  Forum  Topic

I have a weird wobble in the head of my Logo 14, which has been there since its maiden flight.

I call it a wobble because it is way too slow to be a vibration. The amplitude is around 5mm right and left in a hover, with a frequency of around 0.5 seconds.

The blades are fairly well dynamically balanced, and I have tried two different sets from the same manufacturer. I have some other 600mm blades I will try in the next few minutes as well.

Anyone else experience this? Any ideas?

LoopZilla

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-16-2005 08:54 PM  12 years agoPost 2
Send Spam

rrApprentice

Nowhere Land

My Posts: All  Forum  Topic

Check the STATIC tracking of the blades. If it's more than 1 or 2mm off, then you may have found the reason for the wobble.

If it's the same with different blades, maybe the hub (center piece) is not running true.

PM  EMAIL  Attn:RR  Quote
10-17-2005 12:52 AM  12 years agoPost 3
mudbogger2

rrKey Veteran

Hoschton,Ga.

My Posts: All  Forum  Topic

are you running a low headspeed? The dampening on the 14 is fairly stiff and will wobble at lower headspeeds.

Jon Jennings

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 723 views POST REPLY
HomeAircraftHelicopter
e-
Mikado
Other › Logo 14 - Weird head wobble (right and left)
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Monday, July 16 - 6:16 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online