RunRyder RC
WATCH
 1 page 492 views POST REPLY
HomeAircraftHelicopterMain Discussion › heli not lifting off?
10-16-2005 01:13 AM  12 years agoPost 1
dlmob

rrApprentice

Andover, MA.

My Posts: All  Forum  Topic

I have an ark x400 and I've set it up with an outrunner helimax motor and a phoenix 25 esc. Two things: One the governor setup doesn't work well I've tried all options and it just spools up wayyyy tooooo slowwww... and that's on fast start too. So I just set it to standard throttle and not governor. So now when I go to lift it off the ground it doesn't want to take off it just barely lifts off, and that's at 10 degrees pitch. This isn't my first heli setup either so I know what I'm doing to some degree. Until I found out what I did wrong then I'll realize I don't know what I'm doing.

PM  EMAIL  Attn:RR  Quote
10-16-2005 01:18 AM  12 years agoPost 2
E30TECH

rrVeteran

Jefferson, New Jersey

My Posts: All  Forum  Topic

Are the blades facing the right way?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-16-2005 01:25 AM  12 years agoPost 3
dkshema

rrMaster

Cedar Rapids, IA

My Posts: All  Forum  Topic

What kind of head speed are you getting?

Do you have the right size pinion for the motor and main gear?

Is the motor you've chosen suitable for the ARK? Which outrunner Helimax motor? What is its KV rating?

Is your CC25 set up right? Unless it has software version 1.14 or later, your governor mode will probably not work right. You can find out what SW version you have if you have the Phoenix link cable.

How do you have the CC25 set up?

Have you set the throttle endpoints correctly on the CC25?

What batteries are you using to power the heli? Are your solder joints at the ESC, motor, and battery connector good and solid?

What connector are you using for the battery and motor?

Do you have any idea of the overall weight of the machine.

I don't own an ARK, but I do own two T-Rexs, to which the ARK is kind of a kissing cousin...

You might post this question over in the ARK thread here on RR to get a better response.

Dave

PM  EMAIL  GALLERY  Attn:RR  Quote
10-16-2005 03:36 AM  12 years agoPost 4
dlmob

rrApprentice

Andover, MA.

My Posts: All  Forum  Topic

Motor specs are 12-pole, 3600 Kv, 1.6oz, 18amp max current. It has a 14 tooth pitch pinion. The gear ratio is 1:9.85:5. I guess I need to get the USB link to get the latest update. I'm running a kokam 3 cell 1500mah. flying weight about 22 oz, and yes the blades are on correctly.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 492 views POST REPLY
HomeAircraftHelicopterMain Discussion › heli not lifting off?
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, July 16 - 4:22 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online