RunRyder RC
WATCH
 1 page 538 views POST REPLY
HomeAircraftHelicopterThunder TigerOther › Running Lean
10-14-2005 01:36 PM  12 years agoPost 1
safesurfer

rrNovice

Highlands, Scotland

My Posts: All  Forum  Topic

Hi all

My Raptor 50 with TT engine has just started developing a problem.
Its running lean and going into a hover at a much lower engine RPM.
I've checked all the fuel lines and tank, checked all the bolts on the engine are tight. I've just noticed the tail rotor belt seems quite tight, could this be causing the problem ?

Thanks

Mark

PM  EMAIL  Attn:RR  Quote
10-14-2005 02:40 PM  12 years agoPost 2
BarracudaHockey

rrMaster

Jacksonville FL

My Posts: All  Forum  Topic

Dont check the lines, replace the clunk lines and your plug before you do a lot of tweaking.

Andy
AMA 77227
http://www.jaxrc.com

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2005 05:22 PM  12 years agoPost 3
mdm

rrApprentice

PVD

My Posts: All  Forum  Topic

lean
Tell us more. How old is the engine, and you overhauled it ?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2005 06:00 PM  12 years agoPost 4
mbkite

rrVeteran

usa

My Posts: All  Forum  Topic

CK The knobs on the raido hover throttle or pitch .vrb.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2005 10:58 PM  12 years agoPost 5
Sipper

rrApprentice

Poole, Dorset, UK

My Posts: All  Forum  Topic

Your exhaust hasn't worked itself loose has it ?

Sipper

My memory's not as sharp as it used to be. Also, my memory's not as sharp as it used to be.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 538 views POST REPLY
HomeAircraftHelicopterThunder TigerOther › Running Lean
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Wednesday, July 18 - 5:46 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online