RunRyder RC
WATCH
 1 page 810 views POST REPLY
HomeAircraftHelicopterThunder TigerOther › I AM GOING NUTS with the tail kick(RESOLVED!!!
10-14-2005 03:14 AM  12 years agoPost 1
patriot21

rrKey Veteran

Byron,MN

My Posts: All  Forum  Topic

I hate to start this again but here is what i observed tonight...
1.Before the tail kick started this last week, i never had it before even with my low speed at a rich setting..
2. i turned off the revlock... still did it...
3. when i switch to idle up which is about 1850 rpm it gets worse...
4.i have pulled apart the tail and the pin is in place
5. on spool down i notice a slight clicking noise(not by the tail) but around the main rotor... it comes and goes....
6. When i drop from high altitudes.... i sometimes get the wah wahs....
...
Things i have done...
i have leaned the low end... it took care of it for a while but now its getting worse....
Increased the gain of the gyro...

... is my one way bad or going bad....????
how would i know.....
any suggestions... we are going to have a beautiful weekend here and i don;t want it spoiled by this and my wife's patience with me is growing thin cause all i am doing is working on it now...

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2005 04:22 AM  12 years agoPost 2
helibird

rrKey Veteran

St. George, UT

My Posts: All  Forum  Topic

This could be a long shot but I've had the collar come loose and turn on the top bearing, it eats into the collar as the race is made of harder metal. It caused some glitching and tail movement. It's pretty obvious if you loosen the collar and look at the bottom.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2005 02:34 PM  12 years agoPost 3
DRUMMER

rrApprentice

Dover, UK

My Posts: All  Forum  Topic

since I am new to this [at least this time around] i shouldn't be sticking my neck out quite so far, but since you are getting desparate i will offer my input.

I was having a tail kick problem which i put down to the gyro or my set up or my engine leaning out etc. A lot of helpful suggestion were put forward but the one that did it was suggestion I check my trim tabs were set the same in both ordinary and idle up flight. I was embarrased but pleased to find out this was my problem.

This may or may not help.....?
drummer

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2005 06:16 PM  12 years agoPost 4
mickt

rrApprentice

Wiltshire UK

My Posts: All  Forum  Topic

i had the same problem, turned out to be static build up from the belt . Try bonding the tail boom to the engine, made a hell of a difference to mine. I had sent 2 gyro's back to CSM for checking and they were ok. It was CSM that told me to check for static....hope this helps

Mick

PM  EMAIL  GALLERY  Attn:RR  Quote
10-16-2005 05:22 PM  12 years agoPost 5
patriot21

rrKey Veteran

Byron,MN

My Posts: All  Forum  Topic

Well,,, after all the teardown.... PMs sent to AL M.... (thanks for your help)
I finally got rid of it.... It was my high speed needle.... turned it down to 3/4 turned out from fully closed.... checked the head temp and still at 190. its gone

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 810 views POST REPLY
HomeAircraftHelicopterThunder TigerOther › I AM GOING NUTS with the tail kick(RESOLVED!!!
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Saturday, July 21 - 8:38 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online