RunRyder RC
WATCH
 1 page 852 views POST REPLY
HomeAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › Revlock misbehaving... engine tuning?
10-12-2005 03:59 PM  12 years agoPost 1
tchavei

rrProfessor

Portugal

My Posts: All  Forum  Topic

Hi

I have two revlocks mounted on a Evo 50 (OS 50 SX non hyper) and a Freya 70 (OS 70 SZH) Haven't tried them on my new YS91ST.

The revlock works perfectly on the Freya with about 60% gain. Headspeed is rock solid and no overspeeding whatsoever. I'm using a digital 3152 on throttle.

On the OS 50 the story is different... I started with a rich engine and 50% gain on the revlock and a analog 9202 on throttle (I used to have that servo on the Freya where it worked fine). Revlock imediately started to hunt badly.

I have been leaning out the engine and reducing revlocks gain. I have now about 25% gain on the Revlock and my OS 50 is on its lean limit... I wont try to lean it out anymore because I'm starting to notice the rpm hanging a little when I reduce throttle quickly. I'll probably will richen it up 3 or 4 clicks next time.

My problem is that the revlock never stoped hunting completely... The tail doesn't twitch anymore but I can hear the engine going up and down (eventough my friends can't hear it?... maybe I'm going crazy).

Is it possible for the revlock to hunt engine rpm if set too lean? Since I have been reducing both the gain AND leaning out the engine maybe i have reached a point where the revlock is going crazy because of a lean engine?

Any suggestions appreciated.

Cheers
Tony


--------------------
"Perfection and patience usually walk side by side..."

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-12-2005 05:40 PM  12 years agoPost 2
JKos

rrProfessor

Redondo Beach, CA

My Posts: All  Forum  Topic

Tony,
You may want to try the offset throttle linkage method which can help such issues quite a bit. Here is what Colin recommends...

"I set them up with the arm on the barrel at right angles to the pushrod at about idle and then set the servo arm at right angles to the pushrod at about 85% throttle. This gives a very gradual opening of the throttle at the idle end where all the action is and fast movement near full throttle where not so much happens."

- John

RR rules!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-12-2005 07:13 PM  12 years agoPost 3
tchavei

rrProfessor

Portugal

My Posts: All  Forum  Topic

going to try that and putting a 3152 on it... should be faster than the 9202... I also have a 9252 lying around but I think its an overkill for the throttle.

Thx

Will post results

Tony


--------------------
"Perfection and patience usually walk side by side..."

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-12-2005 09:14 PM  12 years agoPost 4
JKos

rrProfessor

Redondo Beach, CA

My Posts: All  Forum  Topic

Try the slower servo first.

- John

RR rules!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-14-2005 11:32 AM  12 years agoPost 5
nivlek

rrProfessor

Norfolk England

My Posts: All  Forum  Topic

Also check to make sure that there is no slop in the servo or the linkage . I guess that telling me to ignore the post worked !

At the end of the day , it gets dark .

PM  EMAIL  Attn:RR  Quote
10-15-2005 01:44 AM  12 years agoPost 6
evolekim

rrNovice

Indianapolis, IN

My Posts: All  Forum  Topic

Take a look at this thread, http://www.runryder.com/t205713p1/

There seems to be a consensus that some mufflers due play well with the revlock

Mike

PM  EMAIL  Attn:RR  Quote
10-15-2005 10:21 AM  12 years agoPost 7
tchavei

rrProfessor

Portugal

My Posts: All  Forum  Topic

There seems to be a consensus that some mufflers due play well with the revlock
You may be right here... the revlock works flawlessly in my Freya (Hatori pipe) but gives me headaches on my sceadu (Funtech)

The Funtech is much quieter than the hatori but its much more restrictive... I wonder if THATS the problem....


Thx

Tony


--------------------
"Perfection and patience usually walk side by side..."

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
11-28-2005 11:13 PM  12 years agoPost 8
spike2450

rrNovice

cornwall, england

My Posts: All  Forum  Topic

hi
I,ve just purchased a second hand freya with os70 engine, can you let me know what settings you are running for the revlock and the ideal headspeeds.
many thanks

PM  EMAIL  Attn:RR  Quote
11-29-2005 12:28 AM  12 years agoPost 9
tchavei

rrProfessor

Portugal

My Posts: All  Forum  Topic

I now have a Ys91 in it but as I recall I used to run the revlock so that I would have 1600 rpm on hover and normal FF and 1700 rpm trying new stuff (16000 / 9.5 = 1684 rpm with max HP but I guess you can torture it a bit and go up to 1750 without loosing power)

The revlock sensitivity was just over 50%

Adjust your throttle curves first so you hover at 50%-55% throttle.

If you need more info, just let me know.

BTW... i forgot all about this topic.

Engine and revlock working perfect on my Evo50 now
Revlock is adjusted to about 40%. The digital 3152 did the trick.
Btw I now changed the carb to a 60B and the engine rocks!


Cheers
Tony


--------------------
"Perfection and patience usually walk side by side..."

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 852 views POST REPLY
HomeAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › Revlock misbehaving... engine tuning?
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Monday, July 16 - 7:47 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online