RunRyder RC
WATCH
 1 page 896 views POST REPLY
HomeAircraftHelicopter
e-
Mikado
Other › Hacker ESC & Hacker C50-13L
10-10-2005 04:20 PM  12 years agoPost 1
scalerc

rrNovice

So Cal

My Posts: All  Forum  Topic

I am new to electric heli's having been strictly a nitro flyer, but am having difficulty setting up my Logo 10 with a Hacker ESC and C50-13L motor. I can't get the ESC to arm. Everything seems to be working but when I turn everything on the best I can get is a one or two rotations of the blades and then it shuts down. I am using a Futaba 8U radio and have tried everything I know to get this to work.

Any help from those in the know would be much appreciated

PM  EMAIL  Attn:RR  Quote
10-10-2005 04:27 PM  12 years agoPost 2
mudbogger2

rrKey Veteran

Hoschton,Ga.

My Posts: All  Forum  Topic

What hacker esc are you using and what batteries?

Jon Jennings

PM  EMAIL  GALLERY  Attn:RR  Quote
10-11-2005 02:46 AM  12 years agoPost 3
scalerc

rrNovice

So Cal

My Posts: All  Forum  Topic

I am using the Hacker 48-O Heli ESC with a NiMH 3300mAH Hump Pack 12 Cell Pack

PM  EMAIL  Attn:RR  Quote
10-11-2005 02:50 AM  12 years agoPost 4
ozace

rrKey Veteran

melbourne, australia

My Posts: All  Forum  Topic

try resetting the esc, it may have settings that dont suit your setup.

we can never have too many, can we ?

PM  EMAIL  Attn:RR  Quote
10-11-2005 12:22 PM  12 years agoPost 5
scalerc

rrNovice

So Cal

My Posts: All  Forum  Topic

Did that several times. Still won't work

PM  EMAIL  Attn:RR  Quote
10-11-2005 12:57 PM  12 years agoPost 6
Dr Lodge

rrElite Veteran

Guildford, Surrey - UK

My Posts: All  Forum  Topic

I had a Hacker ESC that suddenly stopped working and wouldn't arm - think it worked with PPM but not PCM for some reason and the likelihood is that it was static that damaged something in the ESC.

Sounds like you may have a damaged ESC - have you got another receiver that you can try it with, and which is different (PPM/PCM) to the one you're currently using?

Vibe 90, Vibe 50, Vigor CS x2,
Dyna-x, Knight 503D, Logo 10,
TRex 500, Furion, Gaui EP200

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-11-2005 12:58 PM  12 years agoPost 7
Dr Lodge

rrElite Veteran

Guildford, Surrey - UK

My Posts: All  Forum  Topic

see http://runryder.com/t50163p1/?highl...cker+static+ppm

Vibe 90, Vibe 50, Vigor CS x2,
Dyna-x, Knight 503D, Logo 10,
TRex 500, Furion, Gaui EP200

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-11-2005 05:23 PM  12 years agoPost 8
scalerc

rrNovice

So Cal

My Posts: All  Forum  Topic

I am using PCM. I have tried a schulze 18-46 as well and that is the same it won't arm. I believe something in my setup is wrong and am trying to figure out what

PM  EMAIL  Attn:RR  Quote
10-11-2005 05:28 PM  12 years agoPost 9
mudbogger2

rrKey Veteran

Hoschton,Ga.

My Posts: All  Forum  Topic

Have you checked your battery voltage under a load? May be dropping voltage under load (from a bad battery?). Are your soldering skills pretty good. Seen some cold solder joints do wierd stuff.

Jon Jennings

PM  EMAIL  GALLERY  Attn:RR  Quote
10-11-2005 05:35 PM  12 years agoPost 10
scalerc

rrNovice

So Cal

My Posts: All  Forum  Topic

Checked all that. I have tried 2 different batteries. When I use the schulze at the end of turn on I get 2 beeps (disarmed). I have never gotten one beep (armed). I am using a Futaba 8U PCM. I believe my problem may be a radio setup or receiver problem. Does anyone know of any issues using a Futaba Radio and receiver?

PM  EMAIL  Attn:RR  Quote
10-11-2005 05:39 PM  12 years agoPost 11
mudbogger2

rrKey Veteran

Hoschton,Ga.

My Posts: All  Forum  Topic

I use Futaba Tx and RX on all my electric stuff and never had any problems w/ arming. Just a thought but is you throttle trim down? I have seen this keep stuff from arming at times.

Jon Jennings

PM  EMAIL  GALLERY  Attn:RR  Quote
10-11-2005 08:17 PM  12 years agoPost 12
Dr Lodge

rrElite Veteran

Guildford, Surrey - UK

My Posts: All  Forum  Topic

With Futaba and Hacker ESCs you need to have the throttle channel reversed, is it?

Vibe 90, Vibe 50, Vigor CS x2,
Dyna-x, Knight 503D, Logo 10,
TRex 500, Furion, Gaui EP200

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-11-2005 09:19 PM  12 years agoPost 13
scalerc

rrNovice

So Cal

My Posts: All  Forum  Topic

Yes the throttle channel is reversed. I will check the trim. This problem is driving me nuts. I am very anxious to fire up this bird.

PM  EMAIL  Attn:RR  Quote
10-11-2005 09:45 PM  12 years agoPost 14
pjh

rrApprentice

Hampshire England

My Posts: All  Forum  Topic

Try using throttle hold set at a minus figure before you plug in the esc. This is also a good failsafe used by most electric flyers.
Also what is your throttle curve? it should be something like
0/0/90/90/90 in normal(the 90 is only a guessed at figure the important ones are the first 2.

The older i get the faster i was

PM  EMAIL  GALLERY  Attn:RR  Quote
10-11-2005 09:50 PM  12 years agoPost 15
pjh

rrApprentice

Hampshire England

My Posts: All  Forum  Topic

ever looked at logomania?

The older i get the faster i was

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 896 views POST REPLY
HomeAircraftHelicopter
e-
Mikado
Other › Hacker ESC & Hacker C50-13L
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Saturday, July 21 - 8:49 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online