RunRyder RC
WATCH
 1 page 750 views POST REPLY
HomeAircraftHelicopter
e-
Align
Other › Bit of help please on my new t-rex
03-30-2005 05:29 PM  13 years agoPost 1
tomi2004

rrApprentice

west yorkshire,England

My Posts: All  Forum  Topic

Hi all im enjoying my new helicopter which of course is the new t-rex,
im very satisfied with this little beast but today when i was flying my heli it suddenly just lost power............
which im thinking its to do with the speed controler,as when i first set the align esc up, i didnt really no what i was doing....
I still think theres something wrong somewhere along the line because i cant seem to get into programing mode on the esc to check the programing

If anyone can point me in the right direction it'll be grate..

ive also checked some of the threads on the matter but nothing really seems to help me in this cause

Cheers

Tom

PM  EMAIL  GALLERY  Attn:RR  Quote
03-30-2005 05:55 PM  13 years agoPost 2
prof5

rrNovice

leicester

My Posts: All  Forum  Topic

Have a look at http://www.trextuning.com, their is information on sutting up your esc.

stop laughing ! it's not funny

PM  EMAIL  GALLERY  Attn:RR  Quote
03-30-2005 06:27 PM  13 years agoPost 3
jack726

rrVeteran

Cerritos California

My Posts: All  Forum  Topic

Beep
If your Align controller is set up correctly you should hear tones when you turn it on. You first hear a short melody, then a pause then 1 beep then a pause then 2 beeps then a pause then 2 beeps. This indicates that the controller is programmed for option 1 (1beep) option2 (2 beeps) and option 2 (2 beeps)

PM  EMAIL  Attn:RR  Quote
03-30-2005 06:35 PM  13 years agoPost 4
tomi2004

rrApprentice

west yorkshire,England

My Posts: All  Forum  Topic

yeah ive tried that t-rex turning site, it helps loads,but when it says about the esc mine just does'nt want to no..

About the beeps yeah it makes the beeps on powering up...

but do you no anything about the power loss or is that normal????
the battery im using at the moment is a jet-power 2200mah and i must say for a budget li-po its pretty good

PM  EMAIL  GALLERY  Attn:RR  Quote
03-31-2005 01:09 AM  13 years agoPost 5
Brueheli

rrApprentice

Avon Ohio

My Posts: All  Forum  Topic

I am using the Jet Powers also. I have the align escapes and have no problems. It does not appear that any amount of programming will take care of your "sudden loss" of power. All protection settings slowly decrease the power if setting are met ( thermal and battery discharge protections). My escape power down very slowly, allowign me to safely land with alot of time to spare. I cant confirm that the thermal shutdown is as slow.

PM  EMAIL  Attn:RR  Quote
03-31-2005 01:46 AM  13 years agoPost 6
Jarod

rrVeteran

USA

My Posts: All  Forum  Topic

Doubt its the ESC no matter what brand it is. I have had one two many lipos go bad. This is how they behaved when they got cooked once to many times. They would get to 10.5v and drop like a rock. Literally fall from the sky. Most batteries dont drop off so suddenly but it happened with more then one of my TP 2100 packs. I was still new with the EP helis and I admit that I may have abused the batteries before I knew better. They would get so hot you could barely touch them. Maybe that is your problem? Do You have another battery to try?

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 750 views POST REPLY
HomeAircraftHelicopter
e-
Align
Other › Bit of help please on my new t-rex
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Saturday, July 21 - 8:43 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online