RunRyder RC
WATCH
 1 page 428 views POST REPLY
HomeAircraftHelicopterHIROBOOther › Shuttle Build Problem/Question
03-28-2005 09:43 PM  13 years agoPost 1
BarracudaHockey

rrMaster

Jacksonville FL

My Posts: All  Forum  Topic

I'm working on my first Hirobo Shuttle Plus Kit

I got to the step of putting the tail boom on and connecting the belt over the pully. The belt is VERY tight. and I can't get it over the pully without breaking something. I've verified that the tail case is in its slot in the boom and the boom guide pin is lined up on the frame so as far as I can see the boom is all the way seated.

Any ideas? Do I need to do something with the belt? I've built a couple of raptors and they aren't near as tight, and after the belt is on the boom needs to be pulled out a bit to properly tension the belt.

Thanks in advance.
Andy

Andy
AMA 77227
http://www.jaxrc.com

PM  EMAIL  GALLERY  Attn:RR  Quote
03-28-2005 09:54 PM  13 years agoPost 2
z11355

rrMaster

New England

My Posts: All  Forum  Topic

i dont think you have the boom all the way in the body.

try loosening up the screws that hold the boom a bit more.

maybe there is some plastic flash preventing you from gettting the
boom seated properly?

it shouldn't be as hard as you're experiencing

PM  EMAIL  GALLERY  Attn:RR  Quote
03-28-2005 11:29 PM  13 years agoPost 3
I3DM

rrProfessor

Israel

My Posts: All  Forum  Topic

Obviously something is keeping the boom (or tail box) from fitting all the way in as it should.

www.liorzahavi.com

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-29-2005 01:19 AM  13 years agoPost 4
BarracudaHockey

rrMaster

Jacksonville FL

My Posts: All  Forum  Topic

Yep Yep.

Plastic flashing was causing the boom not to seat.

I just wanted to make sure I wasn't missing anything.

Andy
AMA 77227
http://www.jaxrc.com

PM  EMAIL  GALLERY  Attn:RR  Quote
03-29-2005 03:59 AM  13 years agoPost 5
CobraJock24

rrApprentice

Northern California

My Posts: All  Forum  Topic

Andy,
Glad ya got it fixed now... it is far better to post the question here, no matter how simple it may seem, than mess something up and have to wait to get parts!

Last week I did a search here to see if there was a similiar problem I was having, discussed in the past... there it was, I took the recommendation, and how sweet it turned out!

This is the place folks... thanks again to all who have assisted me!

Cheers,
Grover

PM  EMAIL  Attn:RR  Quote
03-29-2005 12:26 PM  13 years agoPost 6
BarracudaHockey

rrMaster

Jacksonville FL

My Posts: All  Forum  Topic

I was kind of surprised. All I hear about is the quality of Hirobo kits and was kind of disappointed at the amount of mold flashing that I have had to clean up on this thing.

It also looks like I am going to have to mod the frame to get my 37 to fit. After speaking to someone though I have found that this is the last of the truly 30 sized framed helis.

Andy
AMA 77227
http://www.jaxrc.com

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 428 views POST REPLY
HomeAircraftHelicopterHIROBOOther › Shuttle Build Problem/Question
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Thursday, July 19 - 7:02 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online