RunRyder RC
WATCH
 1 page 440 views POST REPLY
HomeAircraftHelicopterMain Discussion › YS 61 Roughness in Hover
03-28-2005 04:04 PM  13 years agoPost 1
bobc1

rrApprentice

Southern California

My Posts: All  Forum  Topic

I initially addressed this problem in a post by Scooterpilot titled, "Freya with YS 61STII Surging" http://www.runryder.com/t160935p1/

Since that time, enough has occurred to warrant a new topic posted since it turned out to be a different cause than Scooterpilot's surging problem.

About a month ago, my Freya/YS61/TJ Pro/9253/601/9251 began running rough when hovering, causing the tail to twitch. The heli & engine have less than 10 gallons through them and prior to this, the setup was super smooth.

The engine ran fine when under full load, just ran rough in stable hover situations.

After checking & rechecking the fuel system, including tank, regulator, & carb, & adding a header tank, I had the same problem.

Then I tried a new one way bearing & upgraded to the XSpec aluminum hub. Same results.

Then, at the advice of Dave Shadell (sp?), I purchased a new regulator. Same results.

I did notice that the problem was less pronounced when the TJ Pro was disabled & running on throttle curves alone.

As a last ditch effort, I replaced the well used 9253 throttle servo with a new 9202. Results were great. The engine is once again smooth as glass.

The 9253 appeared to be working fine when tested but obviously was glitching in the air. I would never have guessed the problem to be throttle servo related but it was.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 440 views POST REPLY
HomeAircraftHelicopterMain Discussion › YS 61 Roughness in Hover
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Wednesday, July 18 - 2:11 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online