RunRyder RC
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 2018 views POST REPLY
HomeAircraftHelicopterMiniature Aircraft Whiplash & Fury 55 › Fury Glitch (HELP!!!!)
07-21-2002 12:18 PM  15 years agoPost 1
timrod46

rrNovice

Tennessee

My Posts: All  Forum  Topic

I have a Fury 60 EXP. JR 8103 PPM, 8231's, OS61sxwc,401gyro
have set it up just like the manual said, on 1st test flight it hovered like a rock level flight was good BUT when I make left bank turn the heli starts to jump around until level again, only on left bank turns if you turn left slow like with mostly tail rotor input is't fine. Have checked for lose bolts or any thing lose and there was none have redone all wires rewraped receiver but it's doing the samething,have the same stuff in my other X-Cell no problem. Can anyone HELP?

Tim

PM  EMAIL  Attn:RR  Quote
07-21-2002 01:30 PM  15 years agoPost 2
Wayne

rrVeteran

Davidsonville, Maryland

My Posts: All  Forum  Topic

Is the canopy not secured right and maybethe swashplate is bumping it? It doesn't sound like a radio glitch to me.

Wayne

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
07-21-2002 01:49 PM  15 years agoPost 3
timrod46

rrNovice

Tennessee

My Posts: All  Forum  Topic

Well the glitch is with out the canopy even on yhe heli. Just went back over the thing can't find anything wrong I'm at a lost.

Tim

PM  EMAIL  Attn:RR  Quote
07-21-2002 01:52 PM  15 years agoPost 4
timrod46

rrNovice

Tennessee

My Posts: All  Forum  Topic

Sorry about the type (O yhe = the) and it's just the pitch/al/el servos that
go crazy.

Tim

PM  EMAIL  Attn:RR  Quote
07-22-2002 02:50 AM  15 years agoPost 5
Conrod

rrVeteran

Mount Dora , Florida

My Posts: All  Forum  Topic

glitch
Try swapping out receivers and see what happens.

PM  EMAIL  GALLERY  Attn:RR  Quote
07-22-2002 03:04 AM  15 years agoPost 6
scott3

rrApprentice

Pensacola Florida

My Posts: All  Forum  Topic

I chased a glitch down on mine a couple months ago. The forward screw that attaches the battery tray had cut through the double sided tape and rubbed a smiley face into the battery pack. Might not be your particular problem but definitely a place to check.

PM  EMAIL  Attn:RR  Quote
07-22-2002 08:26 PM  15 years agoPost 7
timrod46

rrNovice

Tennessee

My Posts: All  Forum  Topic

Well I checked out the battery pack all was fine redone some things will try it again this Saturday if it want work guess i'll just shoot the thing

Tim

PM  EMAIL  Attn:RR  Quote
07-23-2002 03:23 AM  15 years agoPost 8
3DP

rrNovice

Marietta, GA

My Posts: All  Forum  Topic

pcm rx
I would suggest using a PCM rx. I started with an FM rx in my fury and had a lot of glitching. I put a PCM rx in, and all the glitching went away.

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
07-23-2002 03:47 AM  15 years agoPost 9
Buzzin Brian

rrProfessor

College Station, Texas

My Posts: All  Forum  Topic

If it glitched with an FM rx, and all you did is add a PCM rx to get rid of it. The problem is still there. It just hasn't reached the point to where it will cause a lock out. Just thought I would point that out. I choose to find the problem, not mask it. Not trying to insult anyone at all. So pelase don't flame me.

Build it, fly it, crash it. Repeat as often as needed.

PM  EMAIL  GALLERY  Attn:RR  Quote
07-23-2002 09:15 AM  15 years agoPost 10
timrod46

rrNovice

Tennessee

My Posts: All  Forum  Topic

Yes I like to find the problem to but have not been able to do it on this Fury, Have found them on others X-cell's, Just thought someone with a Fury could have had a like problem and give a few places to start.

Tim

PM  EMAIL  Attn:RR  Quote
07-23-2002 10:00 AM  15 years agoPost 11
Ken B

rrElite Veteran

Phoenix, AZ

My Posts: All  Forum  Topic

Try these thoughts:

Have any of your locktighted collars loosend.
Look at he bottom collar on the main shaft make sure it's tight.
Did you lock tight the mainshaft to the main bearings?
Have you inspected your tail gears?
Are any of your main bearings dry?

Those are good places to start.

Ken B

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
07-23-2002 10:16 PM  15 years agoPost 12
timrod46

rrNovice

Tennessee

My Posts: All  Forum  Topic

The collars are tight & the one on the bottom also, No the bearings are not lockitghted to main shaft nor are they on my other X-Cell, But is this something that needs to be done on the Furys? As for the tail gears I set them with about 1000th backlash.

Tim

PM  EMAIL  Attn:RR  Quote
07-24-2002 12:31 AM  15 years agoPost 13
d-n-jensen

rrVeteran

Bellevue WA

My Posts: All  Forum  Topic

Try This
Get a palm sander and remove the sandpaper. Turn on the heli and transmitter (this will take 2 people) Use the palm sander as a vibrator to shake the heli while the other person wiggles the sticks to see if any glitching occurs. If so you still have to find what is causeing it but it will tell you that the problem is radio related. I have used this technique to find bad servos and recievers.

PM  EMAIL  GALLERY  Attn:RR  Quote
07-24-2002 07:26 AM  15 years agoPost 14
gnichola

rrApprentice

Santa Rosa, CA. USA

My Posts: All  Forum  Topic

Are you sure it is radio glitching? I setup my pcm rx with throttle setup in failsafe (idle). If it glitches I hear the engine cutting out.

If it is glitching, found at least two problems with mine (I had lots of glitching in the beginning). The bolt into the battery and the middle bearing on the clutch assembly. I dismantled the clutch assembly and locktite'd each of the bearings.

Good luck, Guy

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
07-25-2002 06:03 AM  15 years agoPost 15
Zooms Heli

rrApprentice

Los Angeles

My Posts: All  Forum  Topic

It sounds like you have some mixing going on with the radio or some interaction with your ccpm setup. Have you checked it on the bench by giving collective, elevator, aileron and different combinations? Did you setup the CCPM settings in your radio properly?
Scott

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
07-25-2002 07:14 PM  15 years agoPost 16
ChicoNick

rrNovice

Chico CA

My Posts: All  Forum  Topic

inFURYating glitch
I am also trying to track down a glitch. I have checked every bolt there is. The only thing left to check is the clutch stack but I just dont think that is where it is at. It would start glitching at the end of a tank of fuel, just a small twitch or two. But I went to fly yesterday and when I took off it was glitching bad enough to where I was lucky to get it down. It is really starting to tick me off. I only have 1 and a half gallons through and it has done it from the start.

Nick

PM  EMAIL  Attn:RR  Quote
07-25-2002 08:04 PM  15 years agoPost 17
Zooms Heli

rrApprentice

Los Angeles

My Posts: All  Forum  Topic

Nick,
Sounds to me like you have an electronic glitch. Probably a faulty receiver. Have you tried another receiver? Also, make sure your antenna is not touching any other wires as you could get some interferance. I still lean twords a problem with the receiver, especially because you indicated that it may be getting worse.. Cold solder on the receiver pcb will cause problems. I had similar problems with a bad synthesized Tx module in my 9Z which ultimately caused both of my Fury's to lock out and meet the ground (augmenting the parts business).
I found out after the fact that turning on the radio without the base of the radio antenna raised will fry Tx modules. Tx module failure is rare however, so I still would look at your receiver as a potential source of the problem. I have seen it MANY times with Hitech receivers in Helis.. My feeling is that they do not handle the vibration as well as some of the other receivers on the market.

Good luck. I know it is frusterating.
Scott

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
07-25-2002 08:35 PM  15 years agoPost 18
ChicoNick

rrNovice

Chico CA

My Posts: All  Forum  Topic

I will try a different reciver but everything in the heli is new. I did use an older crystal so I was thinking that might be it. The only other reciver I have it thrashed. I have had it for years. We'll see what happens.

Nick

PM  EMAIL  Attn:RR  Quote
07-25-2002 08:37 PM  15 years agoPost 19
Horacio

rrVeteran

CA

My Posts: All  Forum  Topic

Nick-

You have that one word problem- It's called STYLUS!!! If you can, try another radio. When you come to Fresno, we can put my Futaba in it and see what happens.

See Ya!
Tim

PM  EMAIL  GALLERY  Attn:RR  Quote
07-25-2002 11:10 PM  15 years agoPost 20
ChicoNick

rrNovice

Chico CA

My Posts: All  Forum  Topic

I just might have to take you up on that . A new 9Z would is looking very tempting. I might be down soon, if I am I will let you know.

Nick

PM  EMAIL  Attn:RR  Quote
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 2018 views POST REPLY
HomeAircraftHelicopterMiniature Aircraft Whiplash & Fury 55 › Fury Glitch (HELP!!!!)
 Print TOPIC  Make Suggestion 

 8  Topic Subscribe

Tuesday, July 17 - 3:07 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online