RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 933 views POST REPLY
HomeAircraftHelicopter
e-
Align
Other › only I have this problem?
12-12-2004 08:07 PM  13 years agoPost 1
Renda

rrApprentice

Prague, Czech Republic

My Posts: All  Forum  Topic

Hi,
I just building Trex and I found some very weak points. Mainly some plastic ball links like in No. 71. They are so big that there is too much slop on the original balls and that make it very unprecise. I just swaped the 2 balls on swash plate with raptor steel ones, they have a little bigger diameter. Next the ball links on the compensator...same problem. And finally the plastic balls on part No. 140. It is tail blade holder. With original ball link there is toooo much slop, I used other ball links for No. 146 and drilled bigger holes in No.145.

So far no other problem. Hope It is only my problem, but can use some feedback.

Renda

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
12-13-2004 03:56 AM  13 years agoPost 2
MR GIL

rrNovice

L.I. NY

My Posts: All  Forum  Topic

trex 450x
I TOOK IT FOR A FIRST FLIGHT TO FIND THE SWASH PLATE TO SPLIT APART ..DID THIS HAPPEN TO ANYONE ELSE OR I'M I THE ONLY LUCKY ONE ???

PM  EMAIL  GALLERY  Attn:RR  Quote
12-13-2004 04:02 AM  13 years agoPost 3
vinrx7

rrVeteran

Americas finest city

My Posts: All  Forum  Topic

what do you mean it split apart? Split in half or the bearing part fell out of the plastic housing?

STUPID TREE!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-13-2004 04:14 AM  13 years agoPost 4
tailrotordave

rrVeteran

Burbank, Ca

My Posts: All  Forum  Topic

Mine did it also. The center plastic portion of the swashplate pulls out of the bearing. Mine did it on the bench and not in flight--luckily. I cleaned it all and CA'd the center portion back in the bearing.

PM  EMAIL  GALLERY  Attn:RR  Quote
12-13-2004 07:36 AM  13 years agoPost 5
jackheli

rrProfessor

Vancouver - Canada

My Posts: All  Forum  Topic

There was an advisory from Align in respect to this problem. It seems the bearing was dirty when they applied glue on some of the kits (or something like that). It was posted somewhere in this forum but I couldn't seem to find it.

You should try to split the swasplate with your fingers and if it comes apart you need to clean it up and re-glue.

In the same post it was indicated that the screws that hold the balls to the outer swasplate ring are too long and will bind the swashplate under load. You should therefore grind the tips of the screws so they will not protrude to the inside of the swashplate.

It seems Align is making every effort not only to fix its problems but to call the attention of the community. Some other brands out there wouldn't care less...

It's easy to find an excuse to do wrong. Hard is not to find an excuse to do right.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 933 views POST REPLY
HomeAircraftHelicopter
e-
Align
Other › only I have this problem?
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Wednesday, June 20 - 4:20 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online