RunRyder RC
WATCH
 1 page 702 views POST REPLY
HomeAircraftHelicopter
e-
Elec-Helicopters New or Limited Activity
Ikarus › Piccolo v2 2 to 3 min flight times
12-12-2004 03:53 AM  13 years agoPost 1
jhc10

rrNovice

My Posts: All  Forum  Topic

starting a new thread since it doesn't seem to be an issue with power.

My problem is i'm only getting 1 to 3 minutes of flight time before the piccolo loses power and goes from altitude to ground effect. Even at full power it can't leave ground effect but if i stop the heli for a few minutes give it a rest and try powering up again it shoots up to the ceiling holds altitude for maybe 30 seconds then settles back down to ground effect.

This is with the stock battery, the gws 750mah battery and the kokam 2 cell 1500mah lipos. With the GWS batteries i'm getting at least 10 minutes of flight and 20+ minutes on my 1500 lipo on my hummingbird with plenty of power through out the flight! So I know it's not the batteries.

As for the mesh i put 2 pieces of newspaper in between the pinion and the gear before i tighten the screws. With this method the gear have perfect mesh.

I used the #2 pitch disks and the heli wouldn't lift off at all with the lipos or the gws batteries. When I removed them and used no pitch disks i get 3 minutes max of flight with power to climb as described above.

What gives? I'm so glad i bought the hummingbird first cause i'd probably quit and trash this #$^#$%^$ heli by now!

PM  EMAIL  Attn:RR  Quote
12-12-2004 06:04 AM  13 years agoPost 2
mapmanufacturer

rrApprentice

Bunker Hill, WV

My Posts: All  Forum  Topic

Pinion gear slipping ? I would use alittle CA on the main pinion gear without getting it in the motor.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-12-2004 06:05 AM  13 years agoPost 3
jhc10

rrNovice

My Posts: All  Forum  Topic

i've already ca'd the pinion.

PM  EMAIL  Attn:RR  Quote
12-12-2004 06:11 AM  13 years agoPost 4
mapmanufacturer

rrApprentice

Bunker Hill, WV

My Posts: All  Forum  Topic

Did you break the motor in correctly ? Can also be that the motor is bad. Are you using the piccoboard with the helicopter if so is it getting really hot. Sounds like your pulling to many amps out of the battery and shes dumping on you after 3 minutes.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-12-2004 07:05 AM  13 years agoPost 5
jhc10

rrNovice

My Posts: All  Forum  Topic

i broke it in according to the insructions. ran it unloaded at 25% throttle on one pack. I believed it ran for about 35 minutes before i stopped it.

The piccoboard is only slighlty warm.

I'm thinking of just getting 3s lipos as I think that'll solve the problem.

Just hope it doesn't fry my piccoboard plus

PM  EMAIL  Attn:RR  Quote
12-12-2004 03:59 PM  13 years agoPost 6
jhc10

rrNovice

My Posts: All  Forum  Topic

I'm thinking this is an issue of battery power. The 7 cell and 2 cell lipo's don't have enough volts to fly it. The stock battery is an 8 cell.

Is it the motor that requires this much power? If i were to swap it out with my hummingbird 370 motor would it solve the problem? or is it the piccoboard sucking all the power?

The 370 motor flies my hummingbird for 20+ minutes with the lipos.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 702 views POST REPLY
HomeAircraftHelicopter
e-
Elec-Helicopters New or Limited Activity
Ikarus › Piccolo v2 2 to 3 min flight times
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Tuesday, July 17 - 8:37 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online