RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 578 views POST REPLY
HomeAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › s9252 problems had two burn up
11-08-2004 03:58 AM  13 years agoPost 1
VIGORCS91

rrNovice

Conroe, Tx

My Posts: All  Forum  Topic

I just wanted to know if anyone has had the same problem and if so what is causing it. Well here we go i had my elevator servo on my vigor cs freeeze up while working on it on the bench during set up no binding no cut wires I took it apart and it was tost smelt burned up . I use a 3000 nimh and a heavy duty switch in witch i can find nothen wrong with any of. So i thought no big deal i would send it off and have it fixed in the mean time I went to the hobby shop and picked up a brand new one put it on and during the same time of setting that one up the pitch servo started smoking so i very quickly turn off the switch and you guesed it tost too is there a problem with them i dont know about or do you think something else is wrong. I have been flying them for about 9 months now had a small crash about a month ago but have had them in the air since then if you have any solutions to this i would be appreciative..... do that not like sitting there running in one spot or what when i opened the back of the servo there are two little small black square on the board just behind the motor that is where the burning came from

PM  EMAIL  GALLERY  Attn:RR  Quote
11-08-2004 04:03 AM  13 years agoPost 2
vetrider

rrElite Veteran

Daleville, AL (Ft.Rucker)

My Posts: All  Forum  Topic

4.8V or 6 Volt Battery??

Nolan

PM  EMAIL  GALLERY  Attn:RR  Quote
11-08-2004 04:04 AM  13 years agoPost 3
Greg McFadden

rrKey Veteran

Richland, WA

My Posts: All  Forum  Topic

what voltage are you running on your battery pack?

The silence often, of pure innocence persuades, when speaking fails

PM  EMAIL  GALLERY  Attn:RR  Quote
11-08-2004 04:07 AM  13 years agoPost 4
vetrider

rrElite Veteran

Daleville, AL (Ft.Rucker)

My Posts: All  Forum  Topic

HAHAHA Good timing.

Have you opened both servos and found the same black spot located on both. If so could be Futaba got a bad batch of that component. If so there will be lots of other flyers raising cain soon.

Nolan

PM  EMAIL  GALLERY  Attn:RR  Quote
11-08-2004 05:04 AM  13 years agoPost 5
dkshema

rrMaster

Cedar Rapids, IA

My Posts: All  Forum  Topic

By chance was the linkage bound up with the servo stalled? Good way to roast a servo.

Dave

PM  EMAIL  GALLERY  Attn:RR  Quote
11-08-2004 03:37 PM  13 years agoPost 6
VIGORCS91

rrNovice

Conroe, Tx

My Posts: All  Forum  Topic

I am running 4.8 volts have been fling on those servos for about 9 months and dont think that there was any binding because I take great care in making everything smooth but not going to say that something did not bind. Would it be the receiver? or maybe it was binding not sure just know that it makes no sense. I have checked all the wiring switch and batt it is reading 5.2 on a 1 amp load. What else could i check?

PM  EMAIL  GALLERY  Attn:RR  Quote
11-08-2004 03:54 PM  13 years agoPost 7
Greg McFadden

rrKey Veteran

Richland, WA

My Posts: All  Forum  Topic

did you open the servos up before they burned out?

The silence often, of pure innocence persuades, when speaking fails

PM  EMAIL  GALLERY  Attn:RR  Quote
11-08-2004 04:13 PM  13 years agoPost 8
Dr Lodge

rrElite Veteran

Guildford, Surrey - UK

My Posts: All  Forum  Topic

I've noticed that the anti-rotation block can "drop" while the heli is static on the bench ie the blade holders flop to -ve pitch. Then when you power the radio up, the pins bind against the block rather than engaging in the slots - this introduces extreme binding on the eCCPM servos. Is it possible this happened?

Vibe 90, Vibe 50, Vigor CS x2,
Dyna-x, Knight 503D, Logo 10,
TRex 500, Furion, Gaui EP200

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
11-08-2004 05:05 PM  13 years agoPost 9
VIGORCS91

rrNovice

Conroe, Tx

My Posts: All  Forum  Topic

thanks too all for the help so far and no I did not open them befor they burned up and yes the washout pins could have fallen out if the block and locked up the movement it happens all the time and that is the first thing i checked but that dont mean that while turning off the heli that i did not move that back into place but that does sound more reasonable on why it burned up it was mid stick at the time during set up on the elevator servo

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 578 views POST REPLY
HomeAircraftHelicopterRadio - Servo - Gyro - Gov - Batt › s9252 problems had two burn up
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Sunday, June 24 - 10:17 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online