RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 533 views POST REPLY
11-05-2004 03:51 AM  13 years agoPost 1
Zack429

rrNovice

Brandon MS, USA

My Posts: All  Forum  Topic

I am having trouble with taus's belt conversion.

Where the elevator connects to the pushrod. It comes loose all of the time and causes my heli to crash. I have tried all CAs, Loctite, and epoxy. What else is there that might hold it. Should I just save up for Hubdaves(just took a look at his site and am very impressed[also have a little persuasion from other posts]).

Any help would be appreciated,
Zack

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
11-05-2004 02:50 PM  13 years agoPost 2
msg73

rrApprentice

NJ

My Posts: All  Forum  Topic

How are you connecting the servo spline to the elevator assembly? I used a hex shaft, but instead of drilling out the servo spline and elevator, I heated the hex shaft and melted it into the plastic. Now, there are hex holes in the servo spline and elevator. A drop of CA on each and I inserted the hex shaft.

However...I haven't tried it yet, but it seems strong. The belt/pulleys should be in by tomorrow.

BTW - how many teeth are on your main pulley? I bought both the 40T and 36T just in case.

I'm running a Himax 2025-4200 on 8T w/3s1p packs.

PM  EMAIL  GALLERY  Attn:RR  Quote
11-05-2004 09:13 PM  13 years agoPost 3
eekflyer

rrNovice

Pittsburgh, PA

My Posts: All  Forum  Topic

Have a look here for other ideas to the torsion elevator setup.

http://www.rcgroups.com/forums/show...4&highlight=DIY

EEK

PM  EMAIL  Attn:RR  Quote
11-05-2004 09:50 PM  13 years agoPost 4
Zack429

rrNovice

Brandon MS, USA

My Posts: All  Forum  Topic

I have tried both, neither has held for me. I tried these about 2 weeks ago when I noticed the problem.

.....Zack

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
WATCH
 1 page 533 views POST REPLY
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Friday, June 22 - 5:08 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online