RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 530 views
HelicopterMain Discussion › Tx Stopped Working
04-29-2002 12:00 AM  15 years agoPost 1
PHphishPH

rrNovice

AZ

My Posts: All  Forum  Topic

I was out flying yesterday and the battery in my Futaba 7UAP died, so I charged it this morning for a while. I turned it on and it said 11V as usual, but when I got home after watching some friends fly, it wouldn't work. I can't get the red light to turn on in the charger and I can't get the radio to turn on. Is this the battery or the fuse? If it's the fuse, can I just use any fuse or do I have to get the Futaba fuse? Thanks.
Ryan

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
04-29-2002 12:04 AM  15 years agoPost 2
crash-

rrVeteran

Ca

My Posts: All  Forum  Topic

The fuse you can get at radio shack
You better check the battery
BURN MORE FUEL

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-29-2002 01:32 AM  15 years agoPost 3
PHphishPH

rrNovice

AZ

My Posts: All  Forum  Topic

Is the 7U battery pack made up of 8 500mAh AA batteries? Could I just replace them in the battery sled or is there something special about the AA's in the packs? Thanks again.
Ryan

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
04-29-2002 04:03 AM  15 years agoPost 4
Twobeers

rrKey Veteran

Toronto, Canada

My Posts: All  Forum  Topic

NA

Na nothing special there, I made up my own with 1700am NiMi batteries, runs my Futaba 8UHFS for about 7hrs.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 530 views
HelicopterMain Discussion › Tx Stopped Working
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Monday, December 18 - 8:38 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online