RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 869 views
HelicopterBeginners Corner › bad oscilations
04-28-2002 03:47 AM  15 years agoPost 1
Brutus

rrNovice

Langley B.C. Canada

My Posts: All  Forum  Topic

i have a tt Raptor 60 with the tt 70 pro. still breaking it in but on run-up, just after the rotors start spinning the whole heli starts to oscilate and if i didn't have training gear on i think it would probably tip over. as soon as it gains a little more speed it quits. only lasts for a second at most. just wondering what may be the cause.

PM  EMAIL  Attn:RR  Quote
04-28-2002 04:41 AM  15 years agoPost 2
321

rrApprentice

FL

My Posts: All  Forum  Topic

PM  EMAIL  Attn:RR  Quote
04-28-2002 05:42 AM  15 years agoPost 3
deckerv

rrVeteran

Wellsville, NY

My Posts: All  Forum  Topic

Maybe the gain on the gyro is set too high??

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-28-2002 06:20 PM  15 years agoPost 4
Waldo

rrVeteran

Middle of the corn patch (Iowa)

My Posts: All  Forum  Topic

Did you grease the spindle and dampners with silicon grease or lithium will do too?

[b]Bill[/b]

PM  EMAIL  GALLERY  Attn:RR  Quote
04-30-2002 10:51 PM  15 years agoPost 5
kirk

rrVeteran

Northern, Colorado

My Posts: All  Forum  Topic

Possibly the tracking

Mine was doing that earlier today (first flight after a crash rebuild), and I noticed that my blades were out of track. When I tracked the blades the major oscillations during the run up quit. I also think that checking the feathering spindle for adequate grease is a good idea.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 869 views
HelicopterBeginners Corner › bad oscilations
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Saturday, December 16 - 9:19 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online