RunRyder RC
 6  Topic Subscribe
WATCH
 1 page 252 views POST REPLY
HelicopterRadio - Servo - Gyro - Gov - Batt › Random Align DS610 failure?
04-25-2018 06:51 AM  26 days agoPost 1
eeeeky

rrVeteran

Roosevelt UT USA

My Posts: All  Forum  Topic

Hey all. At a funfly this weekend, i finally got to fly my aurora. I didnt want to do hard 3d with this machine, as i had spent 3 months building it, and simply wanted to just fly it. So it was setup with servos that should have been more than capable(DS610s) It was absolutely perfect. Spotless new canopy that was beautiful. It was setup with align DS610s, and a DS650 tail servo. Output voltage was 5.5v on my scott gray reactor X, so over voltage cant be the reason. I Was doing some mild flying, and it just rolled itself into the ground and exploded all over the runway. I fly futaba 2.4, lipo was freshly charged, and radio was working after the crash. Ive spent a couple days recovering, and have finally dug into the heli. All 3 servos turn smoothly with zero binding, however when powered up one of them goes to the lock, and gets very hot within about 15 seconds. Obviously the servo is bad, but my question is, has this happened to anyone else?? This stupid ass servo destroyed my perfect helicopter, and im furious about it. Obviously i cant do anything but complain amongst us, but i feel like knowing im not the only one might help??

Lets Fly!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-25-2018 12:08 PM  26 days agoPost 2
ICUR1-2

rrElite Veteran

Ottawa, Ontario

My Posts: All  Forum  Topic

I have lost all confidence with Align. I have had new servos go bad luckily on the bench.

spending time, paying attention

PM  EMAIL  GALLERY  Attn:RR  Quote
04-26-2018 03:29 AM  25 days agoPost 3
jimjag

rrNovice

houston texas. usa

My Posts: All  Forum  Topic

super sad that happened to your heli brother...4real been there also...
just chiming in 4 some facts about 610 align servos...many people including myself have been running the align 610 servos on 7.4 volts for several years ...not 615 servos but ds610....no issues at all lasted many crashes lol...Im texting to find out your frequency you were running at time of failure if running over 300hz don't....back it down to 120hz-200hz tops servos will last years...

PM  EMAIL  GALLERY  Attn:RR  Quote
05-02-2018 10:50 AM  19 days agoPost 4
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

Sorry for the loss man that sucks big time, we've all been there! I'm guessing the Aurorra was flybarred?

Servos just fail man but the 610's were always fairly bullet proof and as said above many people ran them on straight 2s li-po with no issues.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
05-05-2018 05:16 PM  15 days agoPost 5
Blue Angel

rrApprentice

Redford, Mi - USA

My Posts: All  Forum  Topic

jimjag: Smarten me up, please. What 300 Hz frequency are you referring to and how do you back it down? Thanks!

Blue Angel

PM  EMAIL  Attn:RR  Quote
05-06-2018 02:55 AM  15 days agoPost 6
eeeeky

rrVeteran

Roosevelt UT USA

My Posts: All  Forum  Topic

Im a little unsure what frequency hes referring to as well. I use a scott gray reactor. Servos plug into the reactor, which plugs into the receiver. Never any kind of frequency adjustment available.

Lets Fly!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
05-08-2018 03:42 AM  13 days agoPost 7
jimjag

rrNovice

houston texas. usa

My Posts: All  Forum  Topic

apologize brother assumed you were running a fbl unit on your heli? if so what kind.... or are you running a fly bar stil? with only a tail gyro?

PM  EMAIL  GALLERY  Attn:RR  Quote
05-08-2018 09:17 AM  13 days agoPost 8
eeeeky

rrVeteran

Roosevelt UT USA

My Posts: All  Forum  Topic

Its flybarred. Only a tail gyro.

Lets Fly!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
05-09-2018 04:46 AM  12 days agoPost 9
jimjag

rrNovice

houston texas. usa

My Posts: All  Forum  Topic

roger that apologize for speaking out of context but refresh rate isn't appropriate to your issue since your your using tail gyro and regular receiver...my advice was for fbl units only...
so yep servo went out nothing you could have done different...

PM  EMAIL  GALLERY  Attn:RR  Quote
05-09-2018 09:03 PM  11 days agoPost 10
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

jimjag
or are you running a fly bar stil? with only a tail gyro?
What else in addition to a tail gyro would he be using with a flybarred setup ??

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
05-09-2018 09:21 PM  11 days agoPost 11
eeeeky

rrVeteran

Roosevelt UT USA

My Posts: All  Forum  Topic

No worries whatsoever. This is just what happens when you trust the cheapest junk in our hobby. Its a wonder people still buy the helis..

Lets Fly!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 252 views POST REPLY
HelicopterRadio - Servo - Gyro - Gov - Batt › Random Align DS610 failure?
 Print TOPIC  Make Suggestion 

 6  Topic Subscribe

Monday, May 21 - 2:10 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online