RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 876 views POST REPLY
HelicopterMain Discussion › Stumped
11-19-2017 07:50 PM  6 months agoPost 1
rcflyerheli

rrKey Veteran

Granbury, TX USA

My Posts: All  Forum  Topic

I thought that I knew at least enough about wiring my ESCs up to do it correctly, but I just ran into something that has me stumped.

I am running a CC Edge 160 on my Trex 700 DFC, on 12s. I have been flying this heli for a couple years now. It previously had a CC Ice 160 with a Hobbywing phase sensor to my Vbar and was running a RX pack to the Vbar. I just recently changed the Ice to the Edge and added a WR BEC to power the Vbar..

I am running a series wiring connection to get the 12s. The red wire from the Edge goes to the plus side of an EC5 plug 1. Out of the -side of the plug, I run a link wire to the + side of plug 2 with the - side going to the black wire on the Edge. I am running the WR BEC off plug 2 with the + wire going to the + side of plug 2 and the - wire going to the - side of plug 2. This way, I can power the BEC and electronics off one of the two flight packs without actually powering the ESC. Then when I am ready to fly, I plug in the other pack to plug 1 and go fly. I get all the correct arming tones from the edge, and no shorts/sparks.

Here is where I am lost. Today, I accidentally plugged plug 1 into a pack without plug 2 being connected. When I did, the ESC powered up (not running the motor, but emitting the 6 beeps for the cell count). I don't understand how it is doing that. When I plug only one pack into plug 1 there isn't a completed power circuit to the Edge. Nor does my BEC power up off plug 1, just the Edge.

My other series setups using EC5 plugs with the same wiring configuration do not do this. Also, if I plug in plug 2 first, I get the BEC to power up with no Edge powering up tones until I plug in plug 1, then I get the 12 beeps from the Edge.

Any ideas?

Goblin 700, Trex 700DFC, Gaui X7, Logo 690SX, Logo 600SX; Trex 470 Trex 500
Amain Team Rep

PM  EMAIL  GALLERY  Attn:RR  Quote
11-19-2017 08:32 PM  6 months agoPost 2
ticedoff8

rrKey Veteran

Morgan Hill, CA. USA

My Posts: All  Forum  Topic

I assume this is your wiring diagram?

Assuming "plug 2" connects to to the top battery pack in this diagram, then it seems the ECS is getting a ground through the BEC.
That is enough to get the ESC to initialize.

You can test that by disconnecting the BEC (You didn't solder the BEC directly to the connector, did you?) and plugging in "plug 2".

If confirmed, I might want to call WR and ask why their BEC is doing this.

Believe 1/2 of what you see and none of what you hear.
Fake News will be the downfall of our Republic!

PM  EMAIL  GALLERY  Attn:RR  Quote
11-19-2017 08:34 PM  6 months agoPost 3
A&J

rrApprentice

Hudson FL 34667

My Posts: All  Forum  Topic

I see got

Lets do the time warp againnn !

PM  EMAIL  GALLERY  Attn:RR  Quote
11-19-2017 08:52 PM  6 months agoPost 4
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

A&J
I see got
????

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
11-19-2017 11:36 PM  6 months agoPost 5
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

I agree with ticedoff's assessment....

Correction....the diagram has the Plug 1 & Plug 2 designators reversed from the verbal explanation of the OP....I think...

I thought the BEC was being powered by means of Plug #2.

Logo 600SXs, 800XX, TDR IIs

PM  EMAIL  Attn:RR  Quote
11-19-2017 11:50 PM  6 months agoPost 6
rcflyerheli

rrKey Veteran

Granbury, TX USA

My Posts: All  Forum  Topic

So do I, and I think that is exactly the way I have them wired, with the exception of the plug between the red and black ESC wires.

In this diagram, if I leave plug 1 disconnected and only plug in plug 2 (note: this is the reverse of my OP, but the theory should be the same), my ESC starts emitting and does emit 6 beeps to signify it is getting 6s voltage.

Now if I only plug in plug 1 of this diagram, my BEC powers up, but no ESC tones. This is what I don't understand. It is acting as if there was a jumper across plug 1, but I don't get any BEC power.

Goblin 700, Trex 700DFC, Gaui X7, Logo 690SX, Logo 600SX; Trex 470 Trex 500
Amain Team Rep

PM  EMAIL  GALLERY  Attn:RR  Quote
11-20-2017 12:20 AM  6 months agoPost 7
rcflyerheli

rrKey Veteran

Granbury, TX USA

My Posts: All  Forum  Topic

I am running WR BECs on two other helis, and I don't see this issue (that I can recall. Unfortunately, this BEC is hard soldered into the leads of plug plug 1 in this diagram. I would sure think that if I had a bridge across the plug that the BEC is wired to, I would get a bright flash when I tried to plug in the pack.

I got two good flights on this setup, and everything seems to be working fine. Like I said earlier, I'm just stumped.

Goblin 700, Trex 700DFC, Gaui X7, Logo 690SX, Logo 600SX; Trex 470 Trex 500
Amain Team Rep

PM  EMAIL  GALLERY  Attn:RR  Quote
11-20-2017 04:13 PM  6 months agoPost 8
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

Pm'd you back on this....

There is a circuit path through the BEC back to the top battery....but the BEC would be reversed biased so to speak.

Logo 600SXs, 800XX, TDR IIs

PM  EMAIL  Attn:RR  Quote
11-22-2017 06:26 AM  6 months agoPost 9
rcflyerheli

rrKey Veteran

Granbury, TX USA

My Posts: All  Forum  Topic

Well, I have to now admit that I do not know nearly as much as I thought I did on wiring these things. My hat is off to all who said the WR BEC was feeding power to complete the cirguit to the Edge.

I cut the + wire between the BEC and the plug, and all problems disappeared. So I then installed a 3mm bullet connector into the red line so that I can disconnect it after a flight, just for safety sake.

Thanks for helping solve my dilemma.

Goblin 700, Trex 700DFC, Gaui X7, Logo 690SX, Logo 600SX; Trex 470 Trex 500
Amain Team Rep

PM  EMAIL  GALLERY  Attn:RR  Quote
11-22-2017 04:14 PM  6 months agoPost 10
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

Glad you got to the bottom of the issue.....

Logo 600SXs, 800XX, TDR IIs

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 876 views POST REPLY
HelicopterMain Discussion › Stumped
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Sunday, May 27 - 4:41 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online