RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 439 views POST REPLY
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Not impressed with MKS
08-07-2017 06:32 PM  74 days agoPost 1
Solmanbandit

rrElite Veteran

Tucson , AZ

My Posts: All  Forum  Topic

I just had a second MKS servo go bad on my 500 and severely upset at this this point. These are high dollar servos and not impressed at all. My first one had the pinion snap off the motor. I sent MKS a message and never got a response. Now a second one is sparking externally when touching the frame. I opened it up to check the gears because it got notchy after that and the gears are burnt. So I put a new set in and seemed ok until I installed it. Started sparking again and now it just spins and won't center. I really don't want to spend another $100 on a servo, but can't really afford to swap them out either.

Trex 700E / Trex 500 ESP - Ikon/ HD 500 - Ikon 2/ Goblin 500 Ikon 2

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2017 03:45 PM  74 days agoPost 2
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

Sparks?

When touching the frame?

Is the frame somehow electrically "hot"?

I think there's another issue besides an MKS servo problem.

Logo 600SXs, 700XX, 800XX

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2017 03:49 PM  74 days agoPost 3
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

What happens if you disconnect the offending servo....and plug a servo extension lead into that servo's port....and with everything powered up....connect the servo extension lead's ground pin to the frame?

Logo 600SXs, 700XX, 800XX

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2017 04:11 PM  74 days agoPost 4
Solmanbandit

rrElite Veteran

Tucson , AZ

My Posts: All  Forum  Topic

It is actually coming through the motor. My gears show heat damage from the sparks. My last servo showed similar damage, but also snapped off the pinion.

Trex 700E / Trex 500 ESP - Ikon/ HD 500 - Ikon 2/ Goblin 500 Ikon 2

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2017 04:34 PM  74 days agoPost 5
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

"Now a second one is sparking externally when touching the frame."

Ok, then what will be your method of isolating that issue?

Logo 600SXs, 700XX, 800XX

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2017 04:36 PM  74 days agoPost 6
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

New servos would not only isolate the issue but eliminate it as well !!

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2017 04:44 PM  74 days agoPost 7
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

How does the lead of that servo look?

Could its positive wire have rubbed through its insulation so that it's touching the frame?

Or at the rubber grommet of the servo lead where it touches the servo casing?

Have to ask.....is it a brand new servo?

Specifically, what MKS servo is it?

Logo 600SXs, 700XX, 800XX

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2017 04:51 PM  74 days agoPost 8
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

Is it possible to post a pic of that servo....and its installation?

A pic is sometimes worth a 1000 words....

Logo 600SXs, 700XX, 800XX

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2017 05:45 PM  74 days agoPost 9
Solmanbandit

rrElite Veteran

Tucson , AZ

My Posts: All  Forum  Topic

The leads are fine and it is shorting through the motor. I did some a reply elsewhere where someone else had the same problem. I just never expected to have this kind of issue from MKS.

Trex 700E / Trex 500 ESP - Ikon/ HD 500 - Ikon 2/ Goblin 500 Ikon 2

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2017 06:10 PM  74 days agoPost 10
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

"it is shorting through the motor."

Rather subjective description.

I'm glad my MKS servos haven't done that.

Just trying to help....

Logo 600SXs, 700XX, 800XX

PM  EMAIL  GALLERY  Attn:RR  Quote
08-16-2017 03:27 PM  66 days agoPost 11
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

If you want reliability always go for Futaba or JR.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
08-16-2017 04:53 PM  66 days agoPost 12
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

Come on....I've had no issues with MKS servos....making a blanket statement like that without details is absurd....

Logo 600SXs, 700XX, 800XX

PM  EMAIL  GALLERY  Attn:RR  Quote
08-27-2017 02:17 PM  55 days agoPost 13
Solmanbandit

rrElite Veteran

Tucson , AZ

My Posts: All  Forum  Topic

I have had futaba servos and wasn't that impressed. Also your statement has no backing. The problem wasn't the motor. I switched servo brand to BK and no issues at all

Trex 700E / Trex 500 ESP - Ikon/ HD 500 - Ikon 2/ Goblin 500 Ikon 2

PM  EMAIL  GALLERY  Attn:RR  Quote
08-27-2017 02:24 PM  55 days agoPost 14
Ace Dude

rrProfessor

USA

My Posts: All  Forum  Topic

I'm very happy with the performance and reliability of the Futaba servos I have been using. Over twenty years in the hobby and I've only used JR and Futaba servos and I only had one JR fail many years ago. All my current helis are using Futaba brushless servos.

  

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 439 views POST REPLY
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Not impressed with MKS
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Saturday, October 21 - 6:25 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online