RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 478 views
Helicopter
e-
Align
T-REX 150 › Trouble binding my 150x
05-27-2017 04:52 AM  6 months agoPost 1
Aces

rrApprentice

Georgetown Tx

My Posts: All  Forum  Topic

Hello everyone. I just purchased The Align 150 X and I can't wait to fly in but so far I have not been able to bind it. I have gone online to YouTube and watched a couple of videos of by Allen Szabo and Jeff Fassbinder and I noticed that there receiver is different than mine. They both show plugging in the satellite on the right-hand side of the receiver to an "antenna" port and putting in a bind plug into a bind port right next to the servo plugs on the top of the receiver . My receiver does not have the antenna port on the side of the receiver. I do have an open slot next to the servo plugs that says "sat" so I am assuming that is for satellite . But no place to put in a bind plug and there was no bind plug that came with my kit.
I first thought that maybe these were pre-production models. Can someone please help me to bind this thing. I have a spectrum Dx8 if that matters.
Here are some pictures to show the receiver that Jeff has in his in the receiver and mine.
Thanks.

Did he crash? Dang, I missed it!

PM  EMAIL  GALLERY  Attn:RR  Quote
05-27-2017 05:36 AM  6 months agoPost 2
knightofcarnage

rrElite Veteran

chicago

My Posts: All  Forum  Topic

Can't help you much because its spec , accept did you update the firmware to 1.1. I know there issues with binding on older firmware to spec.

PM  EMAIL  GALLERY  Attn:RR  Quote
05-28-2017 04:29 AM  6 months agoPost 3
R/C Speed Nut

rrVeteran

Galesburg, Michigan USA

My Posts: All  Forum  Topic

If you have the 150x you have the second generation of the 150. The version featured in those videos is the first generation.
Have you downloaded the manual?
Have you downloaded the mobile app?
You need to connect the app to the 150 by the internal Bluetooth, then tell the 150 to enter Spektrum mode.
Then you can bind a Spektrum satellite.
To bind hold the bind button down on the 150 while you plug in the battery, now your satellite should be flashing.
Bind the TX to the 150.

Watch at YouTube


Mike

Funky Chicken?!!..........I thought this was how you do a piro flip!!

PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2017 06:44 PM  6 months agoPost 4
Aces

rrApprentice

Georgetown Tx

My Posts: All  Forum  Topic

Thank you

That makes sense. I figured it had to be a pre production model or somethjing.
Sorry for the late reply. I have been waiting on a satellite. I solved my "binding" problem. I had a DSM2 sattelite instead of a DSMX!! SO.....now I have been able to bind but i still do not have an operable heli. I have downloaded the app and I have watched all of the setup videos. I set up my radio by watching the video straight from ALIGNS website. I put the satellite in and it bound no problem But when I unplug the satellite it no longer has connection? surely I dont have to try and install this huge satellite on the heli to get it to fly?

Did he crash? Dang, I missed it!

PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2017 06:58 PM  6 months agoPost 5
Aces

rrApprentice

Georgetown Tx

My Posts: All  Forum  Topic

Binding

I watched that video you posted (again) and went through the process step by step and it bound and while the satellite was plugged in it seemed to work just fine (although my throws on cyclic seemed to be not much). But as soon as i disconnect the satellite it loses signal with the radio. Of course the video ends without addressing the use or not of the sattelite to fly. There is just no way something so light could be required to fly with that huge satellite.
Does anyone know if ALIGN has a US based support phone line?

Did he crash? Dang, I missed it!

PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2017 08:33 PM  6 months agoPost 6
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

You were given the answer on your cross post ....

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
06-05-2017 03:14 AM  6 months agoPost 7
Aces

rrApprentice

Georgetown Tx

My Posts: All  Forum  Topic

problems persist

I have the satellite mounted under the receiver as was pointed out to me. But now I can not get the thing to bind?
When I first got the dsmx satellite i was able to bind as normal. I was able to move the cyclic servos and such (although I will say that things did not seem quite right). But as i have stated earlier, I removed the satellite, thinking that i no longer needed it and could not then connect.
Once it was established that i did indeed need the receiver and I got it mounted, i now can not connect? I have tried going through the binding procedures as per the Align's binding procedure video and it blinks all of the right blinks but it does not ultimately connect.
A friend asked if it was reading low throttle (as sometimes you have to calibrate an esc when first setting it up so that it sees low throttle) but I have my throttle settings in normal 0,42,65,78 80. So that should be good.
Any help with this delimma will be appreciated. I am quite sure that it is something very simple that I am missing.

Did he crash? Dang, I missed it!

PM  EMAIL  GALLERY  Attn:RR  Quote
06-06-2017 02:01 AM  6 months agoPost 8
R/C Speed Nut

rrVeteran

Galesburg, Michigan USA

My Posts: All  Forum  Topic

Do you remember what you changed in your transmitter since you were able to get it to bind?
Maybe start with a fresh memory slot in your transmitter.


Mike

Funky Chicken?!!..........I thought this was how you do a piro flip!!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 478 views
Helicopter
e-
Align
T-REX 150 › Trouble binding my 150x
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Friday, December 15 - 12:52 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online