RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 293 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Blade
Blade 300 › Questions about flight modes on a Blade 300CFX
05-11-2017 01:01 AM  5 months agoPost 1
totally_awesome

rrApprentice

Fredericksburg, Virginia

My Posts: All  Forum  Topic

Hello,

After getting my Blade 300CFX back in the air and hovering ok in flight mode 0, I decided to change to flight mode 1...then bad stuff happened. For "unknown reasons" (probably did something stupid) the copter started to spin, as if someone was giving it a lot of rudder input.
So I have a JR9303 radio, I think that the issue was the difference in the throttle curve for the flight modes.

Normal Mode ST-1
Point l 0 70
Point 1 INH 70
Point 2 INH 70
Point 3 50 70
Point 4 INH 70
Point 5 50 70
Point H 50 70

So, was the change in the throttle curve too much from Nornal to ST-1?

Regards, Dave

PM  EMAIL  Attn:RR  Quote
05-11-2017 06:03 AM  5 months agoPost 2
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

After initializing FBL and with throtle hold engaged, pick up heli and turn left then right and make sure pitch slider travels to the each end of the shaft as well as not binding.

If not, revisit SETUP E tail rotor servo end points in the beastx.

Not a speed issue as it can go as high as 100 in throtle curve.
Back in the air
Was it in a crash and if so, what did you repair-replace tail related?

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  GALLERY  BLOGAttn:RR  Quote
05-11-2017 02:04 PM  5 months agoPost 3
pH7

rrKey Veteran

Sterling Heights, MI - USA

My Posts: All  Forum  Topic

On the 9302 in the DeviceSEL menu, make sure that RUD TRIM is set to COM not FM and that your rudder trim is set to zero. If it is set to FM and the rudder trim is set differently in normal and ST1 then you will see the symptom you describe, because the different trim in ST1 will be seen as a rudder command.

I can't imagine that your throttle curve is the cause.

Phil Heavin

PM  EMAIL  GALLERY  Attn:RR  Quote
05-11-2017 10:20 PM  5 months agoPost 4
totally_awesome

rrApprentice

Fredericksburg, Virginia

My Posts: All  Forum  Topic

Hello,

When the copter crashed the following parts need to get replaced, the main gear "(numerous teethe were stripped) and a canopy pin, were the obvious things. I might find a bent main shaft when I replace the main gear.
The copter was able to hover in normal mode with a full range of travel. I also checked the rudder trim in the devsel menu and it was set to COM. So when I get the parts in and replace them I will post reply again to this topic.
I will be setting the throttle curve for ST-1 to a flat line 50% to insure that the mode change is not the issue.

Regards, Dave

PM  EMAIL  Attn:RR  Quote
05-19-2017 11:18 PM  5 months agoPost 5
totally_awesome

rrApprentice

Fredericksburg, Virginia

My Posts: All  Forum  Topic

My parts came in and the copter is back together

Hello,

My parts came in to fix the copter, I needed to replace the main gear, main shaft and a canopy pin. Might find some other stuff wrong when I try to fly it this weekend. A friend of mine told me that a possible reason for the crash was that the tail gain was not set right, possibly 0 or a very low gain in ST-1. However when the copter started to spin, I changed the flight mode to normal and the tail gain should have changed to a acceptable value.
So I will have to do get into setting the tail gain on my copter with a X9303 radio.

Regards, Dave

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 293 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Blade
Blade 300 › Questions about flight modes on a Blade 300CFX
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Friday, October 20 - 12:52 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online