RunRyder RC
 7  Topic Subscribe
WATCH
 3 pages [ <<    <     1     ( 2 )     3     NEXT    >> ] 1323 views
Scorpion Power Scorpion Power
HelicopterMain Discussion › Is it possible? FBL settings change...
02-21-2017 05:20 PM  9 months agoPost 21
w8qz

rrVeteran

Grand Rapids, MI -​USA

My Posts: All  Forum  Topic

In-flight failure is quite possible. Considering the grade of electronics used for hobbies, it is surprising we don't see a lot more of it (my day job is design of high-end commercial and military avionics).

Personally new experience, from a week ago: Did a test flight of an old-school flybarred nitro heli, with lightly-used servos. First flight went fine, just sorting out settings to be tweaked (throws, end points, etc.) Refueled, fired up for the second flight. While gradually easing collective up to take off, a swash servo (as I discovered later) suddenly went hard over to the mechanical stop, and the heli flopped over sideways, trashing a bunch of pieces.

"The helicopter is much easier to design than the aeroplane, but is worthless when done."

PM  EMAIL  GALLERY  Attn:RR  Quote
02-22-2017 04:49 AM  9 months agoPost 22
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

That's gonna be a real hard one to troubleshoot, since something that weird happened during flight....

Logo 600SXs, 800XX, TDR IIs

PM  EMAIL  GALLERY  Attn:RR  Quote
02-27-2017 12:27 AM  8 months agoPost 23
RM3

rrElite Veteran

Killeen, Texas - USA

My Posts: All  Forum  Topic

well testing today in driveway and more funny business...

throttle would go WOT for no reason... Randomly.... not all the time (did it three times out of ten during hover tests)... its a good thing I had my finger on the kill switch... going WOT for just a second while hovering 10 feet in front of yourself is a good way to suck your nuts up real far...

not worth sending it in AFAIC...

guessthe CGY750 is toast.... time to order another.

real shame... those FBL systems are expensive.

showing a preference will only get you into trouble, 90% of everything is crap...

PM  EMAIL  GALLERY  Attn:RR  Quote
02-27-2017 12:50 AM  8 months agoPost 24
JuanRodriguez

rrProfessor

The Villages,​Florida

My Posts: All  Forum  Topic

Sounds like the trash is the place for it

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
02-27-2017 03:21 AM  8 months agoPost 25
balsabasher

rrVeteran

Central Ohio, USA

My Posts: All  Forum  Topic

Is this a belt driven tail heli? Possible static?

Blades; what goes around, comes around!

PM  EMAIL  GALLERY  Attn:RR  Quote
02-27-2017 07:28 PM  8 months agoPost 26
RM3

rrElite Veteran

Killeen, Texas - USA

My Posts: All  Forum  Topic

This is a Torque tube tail.

Worked for over a year without issue. Ive had a gyro fail before after a year of service, but it was a mems sensor failure (before a new anti-vib mount solved that)... this time must be something inside the controller.

anyway, someone offered to pay shipping/handling with full knowledge that it is flawed, but they plan on sending it in to services to see if it can be repaired.

I have a spare CGY750(used) I hope to try but also ordered another new one just in case.

guess this is just part of the hobby...

showing a preference will only get you into trouble, 90% of everything is crap...

PM  EMAIL  GALLERY  Attn:RR  Quote
02-27-2017 07:54 PM  8 months agoPost 27
don s

rrElite Veteran

Chesapeake, VA

My Posts: All  Forum  Topic

I predict it will test fine, then cause another crash on the second flight.

E820, Raptor G4N, X50F/E, E620, Forza 450, and some planks.

PM  EMAIL  GALLERY  Attn:RR  Quote
02-27-2017 08:27 PM  8 months agoPost 28
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

FBL

Worked for over a year without issue. Ive had a gyro fail before after a year of service, but it was a mems sensor failure (before a new anti-vib mount solved that)... this time must be something inside the controller.
Where do you mount them?

For whats its worth, I mount mine (Helicommand-Base version) inside the frame under the tail transmision in my G20 and have not had an issue. Pic in gallery.

Given you can change your settings from radio, it really does not need mounting where you have to see the screen.

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  GALLERY  BLOGAttn:RR  Quote
02-27-2017 08:38 PM  8 months agoPost 29
Heli_Splatter

rrElite Veteran

USA

My Posts: All  Forum  Topic

I would send it in, if it were me. Probably not much they can do, but they might replace or give you a good price on another.

PM  EMAIL  GALLERY  Attn:RR  Quote
02-28-2017 01:34 AM  8 months agoPost 30
RM3

rrElite Veteran

Killeen, Texas - USA

My Posts: All  Forum  Topic

Mount?
custom mount... away from all vibration on its own aluminum base, with 3M tape onto a 1"x1" 2mm thick cast iron plate which in turn is mounted with rubberized adhesive.

Some one offered to buy it as is in hopes of sending in to get repaired if possible for cost of shipping.... so in the mail it went today.

another new unit is on its way to me. a $300 dent in my hobby I was not expecting.... guess thats just the hobby goes.

showing a preference will only get you into trouble, 90% of everything is crap...

PM  EMAIL  GALLERY  Attn:RR  Quote
02-28-2017 01:43 AM  8 months agoPost 31
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

Is it remotely possible...that somehow....the 3M sticky tape came loose a little?

I remember when the AR7000-BX on the Blade 450X came slightly loose the heli would roll right....every time.

Was it stuck down solidly after the crash?

Logo 600SXs, 800XX, TDR IIs

PM  EMAIL  GALLERY  Attn:RR  Quote
02-28-2017 02:02 AM  8 months agoPost 32
RM3

rrElite Veteran

Killeen, Texas - USA

My Posts: All  Forum  Topic

Nope... it was on there pretty good. I had to use a razor blade to cut the 3M tape off last night just to get it off.

the mount was solid too.

Part of every preflight is to wiggle everything, links, servos, blades, canopy, tail control rod, servo function... I even wiggle the gyro... I learned the hard way a long time ago after a GY401 came loose midflight on an Esky Belt CP (Cheap sticky tape)... landed ok but definitely a lesson learned.

After the crash, I took the the sad remains home, looked at the pile in shame, only until the weather got better did I put it all back together... It worked great on the bench except for that servo combo setting... but like I said, running hover tests are a no go as far as the throttle goes.

showing a preference will only get you into trouble, 90% of everything is crap...

PM  EMAIL  GALLERY  Attn:RR  Quote
02-28-2017 02:13 AM  8 months agoPost 33
wc_wickedclown (RIP)

rrProfessor

long beach calif

My Posts: All  Forum  Topic

what bec ere you using ?

Insha Allah made in america

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-28-2017 02:20 AM  8 months agoPost 34
RM3

rrElite Veteran

Killeen, Texas - USA

My Posts: All  Forum  Topic

been using CC 20A Bec forever... got it new at the local HS... run a 3S 2200mah lipo... gives me up to four flights... also has one external Capacitor filter on the RX and another at the CDI.

but I go only 3 flights max, this way it leaves it at storage charge levels.

showing a preference will only get you into trouble, 90% of everything is crap...

PM  EMAIL  GALLERY  Attn:RR  Quote
02-28-2017 06:33 AM  8 months agoPost 35
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

"been using CC 20A Bec"

What voltage is that BEC running at?

Logo 600SXs, 800XX, TDR IIs

PM  EMAIL  GALLERY  Attn:RR  Quote
02-28-2017 02:01 PM  8 months agoPost 36
Pistol Pete

rrProfessor

Seffner, FL

My Posts: All  Forum  Topic

CC 20A

Consider opening the case and inspect the wires.

Gasser vibrations does not favor them where they come out given case design. They may have changed since I got mine.

I did out of reading issues about it and added heat shrink and resoldered them.

~~Enjoying the hobby one flight at a time~~

PM  EMAIL  HOMEPAGE  GALLERY  BLOGAttn:RR  Quote
02-28-2017 04:27 PM  8 months agoPost 37
RM3

rrElite Veteran

Killeen, Texas - USA

My Posts: All  Forum  Topic

set at 5V

all connections are secure, no wire chaffing external or internal. solder connections solid.

...it was just a case of a CGY going bad IMHO...

showing a preference will only get you into trouble, 90% of everything is crap...

PM  EMAIL  GALLERY  Attn:RR  Quote
02-28-2017 11:03 PM  8 months agoPost 38
EEngineer

rrProfessor

TX

My Posts: All  Forum  Topic

"set at 5V"

Can it be run at a higher voltage?

Logo 600SXs, 800XX, TDR IIs

PM  EMAIL  GALLERY  Attn:RR  Quote
02-28-2017 11:13 PM  8 months agoPost 39
Dr.Ben

rrMaster

Richmond, VA, USA

My Posts: All  Forum  Topic

Send it in in lieu of just buying another, because if it is found to be defective, you will be offered and replacement for comfortably less than a new one will cost.

Ben Minor

Team Synergy Team Futaba Team Kontronik USA
Progressive RC

PM  EMAIL  GALLERY  Attn:RR  Quote
03-01-2017 12:19 AM  8 months agoPost 40
Heli_Splatter

rrElite Veteran

USA

My Posts: All  Forum  Topic

He sold it and sent it to new owner.

Story ends. Fade Black. Roll Credits.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 3 pages [ <<    <     1     ( 2 )     3     NEXT    >> ] 1323 views
Scorpion Power Scorpion Power
HelicopterMain Discussion › Is it possible? FBL settings change...
 Print TOPIC  Make Suggestion 

 7  Topic Subscribe

Monday, November 20 - 3:39 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online