RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 373 views
Scorpion Power Scorpion Power
Helicopter
e-
Electric Motors-Controllers-ESC
ESC › iCE2-160 & hk4035-560
12-27-2016 11:41 AM  11 months agoPost 1
Rojoalfa

rrApprentice

Punta de Mata,​Monagas-Venezuela

My Posts: All  Forum  Topic

/
/

My friend has a logo 600 with castle creation ICE 160 and HK4035-560 motor. It is a 700 class design.

Rpm 2100
Pinion 11
Spur 106
12s
Pulse lipo 5000
Fly mode normal with NO governor.
-4.5, 5.5, 10 angle
Flat curve 60% motor.
Head speed change rate: high

According to flight log, max amps = 24, low... Motor is 100 amp capable.

The issue... Rpm is unestable.
Every time you do climbing, you loose 300 rpm and esc is not responding fast enough to compensated.

Why this happens?
Bad esc? Bigger than it should be...

Any comments?

/

Saludos cordiales,

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-27-2016 12:51 PM  11 months agoPost 2
DemetriusUSN

rrVeteran

Virginia Beach, Va​USA

My Posts: All  Forum  Topic

While you were programming the esc, how did you do it? In my opinion, a helicopter that size should be in governor mode. Explain all of your settings in the castle program please?

Minicopter Diabolo 700,Minicopter 550,Compass 6hvu, Devil 380

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-27-2016 05:38 PM  11 months agoPost 3
Rojoalfa

rrApprentice

Punta de Mata,​Monagas-Venezuela

My Posts: All  Forum  Topic

/
/

AT this time, we check esc to be program for helicopter.

Fly mode normal with NO governor.
Rpm control by stick position.

Autorotation enable.

Fixed end Point.

Initial Spool power : low

Head speed change rate: high

Soft cut off rpm lower

Motor at 8khz

Rest of parameter from default.
Throttle curve is a Flat line at 60% all the way.

Every time we do climbing, voltage and current drop at the same time. We suppose when voltage drop, current must increase to mantain same output power.
This issue Last about 6 sec when esc increase current and back to normal 2100rpm.

We change lipo with New ones and same behavior...

My friend have Ohter helis Running with speed control yge 160 amp with no particular issue. ( no governor). Rpm remain constant.

/

Saludos cordiales,

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-27-2016 08:25 PM  11 months agoPost 4
pctomlin

rrVeteran

Texas

My Posts: All  Forum  Topic

Sounds like you have a few issues, the current settings being your major issue. Castle ESCs should not be set with a throttle output below 70%. Also looks like in the cutoffs tab you don't have current limiting set to insensitive and getting one of the cutoffs activating. At the 60% output from the transmitter your headspeed is probably an actual 1500 rpms, not 2100. By your motor/pinion/main gear you can set the ESC to heli, governor, set RPM mode. Input the battery and motor parameters in the tabs and then set desired headspeed boxes, you can run 2200 rpms governed with no issues with your current setup.
Be sure you have the latest firmware (4.22) in the ESC and set the governor gain at 12-14. Typically anything over a governor gain of 15 will start gear chattering.
The voltage/current drop can also be a cold solder joint at one of the battery or motor connections, since it is voltage too I would look hard at the battery connections.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 373 views
Scorpion Power Scorpion Power
Helicopter
e-
Electric Motors-Controllers-ESC
ESC › iCE2-160 & hk4035-560
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Saturday, November 25 - 5:53 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online