RunRyder RC
 9  Topic Subscribe
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 995 views
Scorpion Power Scorpion Power
Helicopter
e-
Castle Electric Components
› Low head speed problem
10-06-2016 12:26 AM  13 months agoPost 1
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

I am getting slow head speeds in 100% throttle curve using cc 120hv talon, scorpion HK 4525 520kv ultimate, msh brain on 12s.... I am using the governor in the esc...... is this set up ok for 700 size. If so where did I go wrong in set up?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-06-2016 02:15 AM  13 months agoPost 2
Santiago P

rrProfessor

South West, Ohio

My Posts: All  Forum  Topic

The components you cite are all ok for a 700 size machine.

Your setup, in this case ESC programming and/or gearing may be way off.

Team Minicopter - PeakAircraft.com
bavarianDEMON- Team Kontronik - Scorpion Motors-

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-06-2016 10:41 AM  13 months agoPost 3
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

13t pinion and 126t main gear is what came with the kit.....could it be something with the governor? When I get it into a hover and flip it to idle 1 or 2 I don't notice any change in head speed but I do in idle 3 but it's not enough head speed to 3d.... just for lite sport flying

PM  EMAIL  GALLERY  Attn:RR  Quote
10-06-2016 10:59 AM  13 months agoPost 4
DemetriusUSN

rrVeteran

Virginia Beach, Va​USA

My Posts: All  Forum  Topic

Can you go over or list your complete settings in your esc,so we can have a better pitcure,also add your main gear and pinion count? Good luck...

Minicopter Diabolo 700,Minicopter 550,Compass 6hvu, Devil 380

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-06-2016 11:39 AM  13 months agoPost 5
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

PM  EMAIL  GALLERY  Attn:RR  Quote
10-06-2016 11:41 AM  13 months agoPost 6
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

If I go any higher then 2006 in head speed it says that it has minimal governor overhead

PM  EMAIL  GALLERY  Attn:RR  Quote
10-06-2016 12:20 PM  13 months agoPost 7
HeliDinoRC

rrNovice

Virginia, USA

My Posts: All  Forum  Topic

Check your Throttle curves in the transmitter. They should be flat horizontal lines for all 3. Normal at 30%, IU 1 at 70% and IU 2 at 100%. Also, make sure the governor is off/inactive in the iKON.

Fail to Plan.....Plan to Fail
Citizen #453
Synergy 766 - Synergy E5SS - Synergy N5c - TT Mini Titan
Futaba 18SZ

PM  EMAIL  GALLERY  Attn:RR  Quote
10-06-2016 01:23 PM  13 months agoPost 8
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

All of my throttle curves are set to those values. How would I go about disabling the governor in msh brain? In the second pic at the bottom says enable governor which is not checked and in the first pic on each flying style says use governor which are also not checked. Is there any other way of disabling I'm not seeing.....? Thank you for you all's help!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-06-2016 03:26 PM  13 months agoPost 9
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

I believe I figured it out....I am running futaba radio and the throttle curve is from -100 to +100. Right now I have the curve set as Idle up 1 +30, idle up 2 +70 and idle up 3 +100. Since it is a curve from -100 to +100 should it be set to idle 1 -30, idle 2 +40 and idle 3 +100?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-06-2016 04:06 PM  13 months agoPost 10
don s

rrElite Veteran

Chesapeake, VA

My Posts: All  Forum  Topic

Did you follow Castle's instructions on how to set the throttle channel's end-points?

E820, Raptor G4N, X50F/E, E620, Forza 450, and some planks.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-06-2016 06:49 PM  13 months agoPost 11
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

yes but I will check again when I get home and change my throttle curves.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-06-2016 10:58 PM  13 months agoPost 12
qroadrunner96

rrNovice

Birmingham, AL

My Posts: All  Forum  Topic

ESC calibration

Your throttle curves should be flat at idle 1 = 30%, Idle 2 = 70% and idle 3 = 100%, you also must calibrate your ESC with your TX, go to your endpoints and lower the high and low to both 30, make sure your normal is 0 to 100% and raise your collective to the highest point and for safety remove all blades, now you can use just a 4S pack or higher whichever you want for the ESC and once you've turned on ESC you'll hear a chime which is notifying you of program mode now while the side is blinking/flashing raise the number from 30 until you hear a beep from the motor then go 2 points higher and lower the collective to its lowest point you will hear another chime the raise the other point from 30 until it chimes then 2 points higher and now you have calibrated your ESC and radio. There is videos under castle support if you need further examples.

Please watch the video's for your throttle hold also.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2016 02:01 AM  13 months agoPost 13
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

I have done all of the programming of the esc and end points for the throttle and all of my idle up are at the recommended curves....I am still getting a very low head speed....I am for a loss at this point on what is going on. I have had a 700 helicopter before with plenty of authority because the head speed was much faster then what I am getting....

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2016 02:04 AM  13 months agoPost 14
don s

rrElite Veteran

Chesapeake, VA

My Posts: All  Forum  Topic

Are you sure the ESC is seeing all 12 cells?

E820, Raptor G4N, X50F/E, E620, Forza 450, and some planks.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2016 02:30 AM  13 months agoPost 15
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

Yes

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2016 03:26 AM  13 months agoPost 16
pctomlin

rrVeteran

Texas

My Posts: All  Forum  Topic

Need to see a screen shot of Brain setup software tab 5 at low and high throttle and tab 12 min/max settings. Your problem could be here.

Sorry, looking at your screen shots again, you are using an old version of Brain software, need tab 4 transmitter and tab 10.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2016 03:54 AM  13 months agoPost 17
HeliDinoRC

rrNovice

Virginia, USA

My Posts: All  Forum  Topic

Are you running the Futaba 18SZ by chance? With the -100 to 100 Throttle range in your TX you need to convert the curve percentages in the TX. Here's a little formula from Danny Dugger of Team Synergy. X=2(V-50)
Where V = the 0-100% value.

In other words, the iKON needs to see flat 30, 70 and 100. For Normal: 30-50 = -20. -20 * 2 = -40. So, your normal curve in the TX is flat -40. IU1: 70 - 50 = 20. 20 * 2 = 40.

Your flat TC should be programmed in the TX as: Normal is -40, IU2 is 40 and IU2 100.

Currently if you have the curve set at 30 and 70 for normal and IU1 in the TX, the iKON is seeing 65% for normal and 85% for IU1.

Just something to check...

Fail to Plan.....Plan to Fail
Citizen #453
Synergy 766 - Synergy E5SS - Synergy N5c - TT Mini Titan
Futaba 18SZ

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2016 05:16 AM  13 months agoPost 18
plakkertje

rrApprentice

belgium

My Posts: All  Forum  Topic

You can place the thr whire direktly in to the reciver,port 3
and run the castle in gov mode, like jou do.
flat thr 30 70 100

PM  EMAIL  Attn:RR  Quote
10-07-2016 11:58 AM  13 months agoPost 19
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

You can place the thr whire direktly in to the reciver,port 3
and run the castle in gov mode, like jou do.
flat thr 30 70 100

This seems like the simplest solution and what I should have done from the start since I am running the esc governor....completely bypass the brain. I will do this and report back...Thank you all for your help so far!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2016 01:37 PM  13 months agoPost 20
mtickel25

rrNovice

columbia, s.c. -​u.s.a.

My Posts: All  Forum  Topic

Well I plugged the esc directly into the receiver and relearned the throttle endpoints and double checked my throttle curves but headspeed still hasn't changed. The headspeeds are idle 1 1800, idle 2 1900 and idle 3 2000. Anything over 2000 the esc states minimal governor overhead....so I would assume going over that would not be a good idea to get a faster headspeed. I did notice when I am in normal flight and switch to idle 1 with throttle stick a little over half... the headspeed decreases but I do notice a change in headspead increasing going to idle 2 and 3. I can do sport flying with this heli no problem with its current headspeed but if I do any aggressive pitch moves it bogs down and kicks the tail a good bit.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 995 views
Scorpion Power Scorpion Power
Helicopter
e-
Castle Electric Components
› Low head speed problem
 Print TOPIC  Make Suggestion 

 9  Topic Subscribe

Wednesday, November 22 - 8:04 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online