RunRyder RC
 10  Topic Subscribe
WATCH  2 pages [ <<    <     1     ( 2 )    >    >> ] 1022 views POST REPLY
Scorpion Power Hitec RCD
Home > Flybarless Rotor Head Systems > BeastX > Please Help-BeastX pitching to left
iyoy

Veteran

Bacolod City, Philippines

My Posts: All  Forum  Topic

550L

Hi guys,

I'm also a first timer with the Microbeast PLUS. I have the version 4.1.5 which came with my T-Rex 550L Dominator Super Combo. I tried to follow the manuals of Align and of Microbeast as best as I could using a standard receiver (not SBus) setup Futaba R7008SB and a T14SG. My test flight went ok. I just did normal hover just to get the feel of the heli. The head speed seemed slow and the hover was a bit wobbly with a noticeable up and down bob of the tail. After about five minutes, I decided to end the flight and just as I was about to land from a height of two feet, the heli just froze and drifted off in a bank and the blades hit the ground. Blades were wrecked and the front TT drive pinion stripped. The DFC links detached from the swashplate but this was probably caused by the impact.the battery showed 3.9v per cell after and everything seemed to be functioning when I tested after the crash. I don't have a separate receiver battery.

Any analysis to solve the problem highly appreciated. Thanks!

iyoy

01-14-2017 02:04 AM
PM  EMAIL  GALLERY  Attn:RR
JuanRodriguez

Elite Veteran

The Villages, Florida

My Posts: All  Forum  Topic

Rather than hijacking this thread, you might get a better response if you start a new thread of your own....

Been there, done that and old enough to know better.....

01-14-2017 02:16 PM
PM  EMAIL  GALLERY  Attn:RR
iyoy

Veteran

Bacolod City, Philippines

My Posts: All  Forum  Topic

Juan Rodriguez

Sorry I didn't mean to hijack this thread. I was reading the comments and I thought by sharing a similar experience with the Microbeast Plus I could show that the occurrence of the problem is quite frequent and others, myself included could learn from the constructive comments posted here. I meant no offense to anyone.

iyoy

01-14-2017 03:37 PM
PM  EMAIL  GALLERY  Attn:RR
JuanRodriguez

Elite Veteran

The Villages, Florida

My Posts: All  Forum  Topic

You didn't offend anyone.....

My comment was constructive in nature..... I believe that you would get a better response by starting your own "fresh" thread.......

Been there, done that and old enough to know better.....

01-14-2017 11:26 PM
PM  EMAIL  GALLERY  Attn:RR
AgentOrange

Veteran

Jacksonville, Florida

My Posts: All  Forum  Topic

I am having the same issue as the OP. My heli has been stored away for little over a year and started it up and hovered it and it seemed fine then I did some collective pumps and when I stopped it rolled to the left. I recovered it and landed it. Redid the setup again and flew it with the same problem. Redid the setup a third time with the same results. My heli did not crash as I was high enough to recover and hit throttle hold and land it safely. I am going to replace my tape and try again tomorrow. Also I have mine strapped down would that make any difference at all.

Trying not to put them in the dirt.

03-01-2017 01:39 AM
PM  EMAIL  GALLERY  Attn:RR
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

I am going to replace my tape and try again tomorrow. Also I have mine strapped down would that make any difference at all.
Yes replace the tape if it's a nitro with old tape. Don't use the thick white pad though, just one piece of the thin 3M grey pad and no need to strap it down. Strapping down gyros can make things worse.

60% of the time, it works every time!

03-01-2017 03:52 PM
PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
AgentOrange

Veteran

Jacksonville, Florida

My Posts: All  Forum  Topic

Well just wanted to report that I did replace my tape and heli flies like a champ. No issues any more. Flew a whole tank with no issues so thanks for the help. To the OP I hope you get yours figured out.

Trying not to put them in the dirt.

03-01-2017 09:57 PM
PM  EMAIL  GALLERY  Attn:RR
WATCH  2 pages [ <<    <     1     ( 2 )    >    >> ] 1022 views POST REPLY
ProModeler Scorpion Power
Home > Flybarless Rotor Head Systems > BeastX > Please Help-BeastX pitching to left
 Print TOPIC Advertisers 

 10  Topic Subscribe

Thursday, March 23 - 5:17 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies