RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 528 views
Scorpion Power Scorpion Power
09-11-2016 01:12 AM  14 months agoPost 1
WessCo

rrApprentice

Summerville, GA USA

My Posts: All  Forum  Topic

I am having a random problem with a Futaba BLS276SV. Occasionally, it will not allow for right rudder during flight. I run it on 7.5v. The helicopter is a Logo 600sx, Neo fbl unit, VBar Control radio. I can land, unplug the battery, then re-initalize. It then acts fine.

MikadoUSA
VTeam
OptipowerUSA

PM  EMAIL  GALLERY  Attn:RR  Quote
09-11-2016 02:19 AM  14 months agoPost 2
don s

rrElite Veteran

Chesapeake, VA

My Posts: All  Forum  Topic

Swap it out for a different servo and see what happens.

E820, Raptor G4N, X50F/E, E620, Forza 450, and some planks.

PM  EMAIL  GALLERY  Attn:RR  Quote
09-14-2016 10:37 AM  14 months agoPost 3
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

You say 'in flight' but do you get full right rudder 'on the bench'?

Is the servo getting hot after a flight?

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-14-2016 10:59 AM  14 months agoPost 4
WessCo

rrApprentice

Summerville, GA USA

My Posts: All  Forum  Topic

After rebooting. Dr. Ben gave me a few things to try. Think the easiest thing will be to swap servos and double check mechanics.

MikadoUSA
VTeam
OptipowerUSA

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 528 views
Scorpion Power Scorpion Power
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Saturday, November 18 - 9:26 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online