RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 244 views TOPIC CLOSED
ProModeler Scorpion Power
HelicopterMain Discussion › MicroBeast Plus HD cannot set Radio step A
07-04-2016 06:15 PM  11 months agoPost 1
Heli_Splatter

Elite Veteran

Silver Spring, MD by way of Sidney, Ne - USA

My Posts: All  Forum  Topic

I cannot seem to select the proper radio... I turn on the microbeast while holding down the button... the b light starts blinking, not the A light as expected.

I should mention that I have applied the update in hopes that it fix the problem... before the A light would blink, but it would not cycle through the radio selections, only the Red Solid LED would be displayed.

This is a brand new MicroBeast Plus, I have two other microbeasts and have set them up without problem.

Not getting anywhere, so I am thinking this is DOA... or there is a trick. Yes I have read that you must quickpress to get out of A menu...I have tried a total system reset, I cannot seem to do that.

Does anyone have a good idea?

PM  EMAIL  GALLERY  Attn:RR
07-05-2016 10:52 PM  11 months agoPost 2
Heli_Splatter

Elite Veteran

Silver Spring, MD by way of Sidney, Ne - USA

My Posts: All  Forum  Topic

As you might have guessed, I talked to Tech Support this morning and it is non-functioning and will need to be sent in for repair/replacement. There was nothing they could do to help me.

Carry on with your day and ignore my intrusion.

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 244 views TOPIC CLOSED
GLOBAL 3D ProModeler
HelicopterMain Discussion › MicroBeast Plus HD cannot set Radio step A
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Thursday, June 22 - 7:25 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online