RunRyder RC
 5  Topic Subscribe
WATCH
 1 page 668 views
Helicopter
e-
Electric General Discussion
› T-Rex 600, won't idle up
12-21-2015 05:56 AM  24 months agoPost 1
DennisH

rrApprentice

Baton Rouge Louisiana USA

My Posts: All  Forum  Topic

I have flown my T-Rex 600 for several months. I have three batteries, all charged and ready. This weekend for some reason, the motor would not idle up in normal mode, stunt 1, or stunt 2 mode. It goes about 25% and stops. It does this on all three batteries, 22.2 6,000Mah. Everything else seems to be working correctly. It flew great 2 weeks ago. I have checked everything I know to check, I am at a loss. Your assistance will be appreciated.

I am using a DX-9 radio.

Dennis

UPDATE: I removed the rotor blades and tested the unit. In all three modes, normal, stunt 1, and stunt 2, the motor will die and will start back up. Without the blades, it seems very slow to wind back up. Battery voltage is OK. I tried wiggling wires, nothing changed. I did wind it up several times, but as I move the elevator, this is when the motor would cut out. This happened all of a sudden. It flew great the last time out. When I tried to fly this weekend, it never left the ground.

PM  EMAIL  GALLERY  Attn:RR  Quote
12-21-2015 10:12 AM  24 months agoPost 2
wrongler

rrProfessor

Brewerton, New York

My Posts: All  Forum  Topic

I would check the setting in the ESC and also go over your TX settings. Also check solder joints from the ESC to the motor. If that does nothing you may have a bad motor or ESC.
If none of these help, and you do find the problem, please let us know what it was.

Bill Whittaker

PM  EMAIL  GALLERY  Attn:RR  Quote
12-21-2015 01:04 PM  24 months agoPost 3
DemetriusUSN

rrVeteran

Virginia Beach, Va USA

My Posts: All  Forum  Topic

Yea......what that wrongler said. It sounds like a esc problem, is it a Align esc? If so, I have had those act crazy at times. Go over your settings making sure nothing has changed. When I had the esc go crazy it was after a crash, so be careful with spooling up and what not. If you need any other help, let us know.

Minicopter Diabolo 700,Minicopter 550,Compass 6hvu, Devil 380

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-21-2015 08:00 PM  24 months agoPost 4
DennisH

rrApprentice

Baton Rouge Louisiana USA

My Posts: All  Forum  Topic

I am meeting up with a friend Wednesday who has the software to check everything out. I hope he comes up with a solution pretty quick.

Otherwise, I will patiently wait. I looked at it again this morning, but nothing new to report.

Thanks for your input and hopefully more will be posted. I will post the final fix for this problem with details.

Dennis

PM  EMAIL  GALLERY  Attn:RR  Quote
12-24-2015 09:15 AM  24 months agoPost 5
DennisH

rrApprentice

Baton Rouge Louisiana USA

My Posts: All  Forum  Topic

Checked the ESC out today along with everything else. It appears the ESC low voltage setting was the culprit. Somehow the setting ended up shutting the motor down at 30% throttle. We change this to almost (0), and all seems to be operating well.

I discharged a battery testing the unit out just to make sure. We just did a lot of work on the unit and this is the first time I had an issue like this. Learned a good lesson, I will go from here.

Thanks to all for your help.

Dennis

PM  EMAIL  GALLERY  Attn:RR  Quote
12-24-2015 09:41 AM  24 months agoPost 6
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

What would concern me is "how" the setting changed all of a sudden and all by itself !!

If it were mine, I would replace the ESC with a new one.... cheap insurance vs risking damaging your heli...... or worse yet, injuring yourself or others if that ESC were to fail during flight....

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
12-26-2015 12:08 PM  23 months agoPost 7
DennisH

rrApprentice

Baton Rouge Louisiana USA

My Posts: All  Forum  Topic

Juan, Good Point.

I will have to admit, I haven't flown the Helo in "normal" mode much if any. So it's hard to say at this point. I will be very careful with the next few flights.

I just need the weather to co-operate here in South Louisiana. Doesn't look good for flying in the next few days.

I have been getting some practice time in with my 450 in between thundershowers!

PM  EMAIL  GALLERY  Attn:RR  Quote
01-14-2016 03:04 PM  23 months agoPost 8
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

How cold is it there? Li-po's don't like freezing temps, the voltage can drop way down. I used to warm my packs in the car with the heater on on cold days.

Nitros are best for winter flying.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-16-2016 07:01 PM  20 months agoPost 9
DennisH

rrApprentice

Baton Rouge Louisiana USA

My Posts: All  Forum  Topic

T-Rex 600, won't idle up

We finally narrowed it down.

It was a servo extension that was causing the problem.

We removed it, and all was instantly working great.

Hopefully this will help someone else.

Dennis

PM  EMAIL  GALLERY  Attn:RR  Quote
04-17-2016 01:26 AM  20 months agoPost 10
JuanRodriguez

rrProfessor

The Villages, Florida

My Posts: All  Forum  Topic

Great that you found the problem !! And thank you for taking the time to come back and post your update, much appreciated !

Been there, done that and old enough to know better.....

PM  EMAIL  GALLERY  Attn:RR  Quote
04-17-2016 03:54 AM  20 months agoPost 11
DennisH

rrApprentice

Baton Rouge Louisiana USA

My Posts: All  Forum  Topic

600 won't idle up

Juan, hopefully it will help someone else. It almost got the best of us, but we didn't give up.

Dennis

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 668 views
Helicopter
e-
Electric General Discussion
› T-Rex 600, won't idle up
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Wednesday, December 13 - 3:13 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online