RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 691 views
Helicopter
e-
Electric Battery-Charger-pSupply
› Brand new 4010 lets out the magic smoke?!
10-23-2015 10:50 PM  25 months agoPost 1
Dan Minick

rrKey Veteran

Columbus, WI

My Posts: All  Forum  Topic

Hey guys I just got a brand new 4010 DUO the day before yesterday. Downloaded the update software and hooked up my USB, and when I plugged a 6s pack into the EC5 poof. Huge arc and a cloud of smoke from inside the case. What did I do wrong?

Team Synergy, Team FBL Rotors-------if its not broke...it will be!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2015 12:44 AM  25 months agoPost 2
Gregor99

rrElite Veteran

Western Wa

My Posts: All  Forum  Topic

What did I do wrong?
Checklist:
1) Power supply suitable for the load and delivery the correct voltage.
2) Charger plugged in and powered up BEFORE connecting the pack.
3) Polarity of the main leads, packs and balance boards/connectors all known and correct.
4) Per iCharger documentation, connect the balance connector first, before connecting main leads. Not likely to cause an arc like you described.
5) If parallel charging, all packs and individual cells are in a known state and close to each other.

If you passed the checklist, I don't see that you did anything wrong. Contact the vendor for service or replacement.

Revolectrix Beta Team

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2015 02:20 AM  25 months agoPost 3
Dan Minick

rrKey Veteran

Columbus, WI

My Posts: All  Forum  Topic

I never made it to the charging checklist. The EC5 connector I speak of was on the input side of the charger. I was just trying to power the charger to update the software. Never even had the balance and main leads out of the package. I contacted them yesterday, need to go through all the steps before they send me a new one I guess

Team Synergy, Team FBL Rotors-------if its not broke...it will be!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2015 04:27 AM  25 months agoPost 4
Gregor99

rrElite Veteran

Western Wa

My Posts: All  Forum  Topic

What power supply are you running? After a spark like you describe, I wouldn't apply power to the charger again.

Revolectrix Beta Team

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2015 08:12 AM  25 months agoPost 5
Heli Fanatix

rrVeteran

Fountain Valley, CA

My Posts: All  Forum  Topic

You did nothing wrong Dan,

Mines let the magic smoke when I try to discharge on channel 1. I requested an RMA from ProgressiveRC and they had it back to me within 10 days. Was in constant communication via email and excellent service.

I have a PL8 and 4010 and they complimented each other's short coming. I feel everyone should have a backup charger and PSU.

BTW
There is a procedure you need to be careful when charging multiple packs per channel. Hooking 2 packs to a channel requires proper connection or else the external balance board and internal balance/charging circuit will short.

- Scott

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2015 02:02 PM  25 months agoPost 6
Dan Minick

rrKey Veteran

Columbus, WI

My Posts: All  Forum  Topic

I have not yet hooked it to a "power supply" it was being powered by a 6s lipo at the time.

Thanks Scott! I didn't think I could screw up powering on a charger

Team Synergy, Team FBL Rotors-------if its not broke...it will be!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-26-2015 05:03 PM  25 months agoPost 7
ticedoff8

rrKey Veteran

Morgan Hill, CA. USA

My Posts: All  Forum  Topic

The 6S pack is around 22V, so using that as the input should not have been a problem.

I power up my 308 Duo with a 3S pack on the input and discharge my 6S packs on the mains. I've never had a problem.

Assuming it didn't smoke the PC (through the USB cable), I would rule out some kind of weird ground-loop or some internal USB related short.

Even if the balancer is connected wrong, or the battery's balance cords are x-connected, you should smoke the balance lead on the battery, not the charger (don't ask how I know that).

The guys at RC Buddy warn about using crap power supplies with the 4010 or the 308. A bad generator or a car battery can smoke the 4010 or 308.

Believe 1/2 of what you see and none of what you hear.
Fake News will be the downfall of our Republic!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-26-2015 09:58 PM  25 months agoPost 8
Dan Minick

rrKey Veteran

Columbus, WI

My Posts: All  Forum  Topic

I have got an Eltek 52 volt, 2000 watt supply that will be powering it eventually, actually a pair

Team Synergy, Team FBL Rotors-------if its not broke...it will be!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-29-2015 06:26 PM  25 months agoPost 9
ticedoff8

rrKey Veteran

Morgan Hill, CA. USA

My Posts: All  Forum  Topic

The specs for the iCharger 4010 states the maximum input voltage is 50V.

You may think a 52V input is okay. That's your choice.

But, if the new 4010 smokes again, you may want to get a lower voltage power supply.

Believe 1/2 of what you see and none of what you hear.
Fake News will be the downfall of our Republic!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-29-2015 06:35 PM  25 months agoPost 10
Dan Minick

rrKey Veteran

Columbus, WI

My Posts: All  Forum  Topic

I'm aware, they are adjustable, again the bad charger was never hooked to this power supply. I got it sent back, new one should be here next week

Team Synergy, Team FBL Rotors-------if its not broke...it will be!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 691 views
Helicopter
e-
Electric Battery-Charger-pSupply
› Brand new 4010 lets out the magic smoke?!
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Monday, December 11 - 11:32 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online