RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 1506 views POST REPLY
HelicopterMain Discussion › 6xi binds with ar7000 but servos do not operate
06-09-2014 03:27 AM  3 years agoPost 1
tomtek

rrApprentice

ga

My Posts: All  Forum  Topic

I have a spectrum 6xi and the spectrum AR7000 with one satellite. I can bind the transmitter with the AR7000 successfully. When I plug in the digital servos into the AR7000 I hear them buzzing but my sticks on the transmitter will not move the servos at all. Any suggestions?

PM  EMAIL  GALLERY  Attn:RR  Quote
06-09-2014 03:45 AM  3 years agoPost 2
dkshema

rrMaster

Cedar Rapids, IA

My Posts: All  Forum  Topic

If your 6i supports DSMx mode, and you are attempting to bind in DSMx mode, that could be a problem as the AR7000 is DSM2 only. (Is your satellite receiver ALSO a DSM2 receiver)? If not, it MUST be a DSM2 satellite.

Bind in DSM2 mode only.

-----
Dave

* Making the World Better -- One Helicopter at a time! *

Team Heliproz

PM  EMAIL  GALLERY  Attn:RR  Quote
06-09-2014 11:47 AM  3 years agoPost 3
tomtek

rrApprentice

ga

My Posts: All  Forum  Topic

Thank you Dkshema. My 6xi binds with the ar7000 successfully. The problem is none of the servos move with stick movements. The servos are getting power because I can hear them. The 6xi is bound in DSM2 mode according to the transmitter.

PM  EMAIL  GALLERY  Attn:RR  Quote
06-09-2014 11:49 AM  3 years agoPost 4
Heli_Splatter

rrElite Veteran

USA

My Posts: All  Forum  Topic

Are you sure that they are plugged in correctly and you have not reversed signal and ground?

PM  EMAIL  GALLERY  Attn:RR  Quote
06-10-2014 04:50 AM  3 years agoPost 5
JEEPWORLD2002/2

rrKey Veteran

Blue Bell, Pa

My Posts: All  Forum  Topic

I m thinking you have to set up the tx for the ccpm mode 3 servo 120 then move the collective to mid way and power up the Rx most esc need to see low stick to arm the esc by moving the collective left stick to mid way the esc can't arm then while Rx powered up move the collective up to top did the servos move togather ?? If so move forward with programming if not either reverse the + # to negative # in the swash menu or use reversing menu to get them moving the same way.

Trex600n,Trex500,MR25,MikadoLoGo5003d/KDE,Goblin 380XNova,CastleCreations,Ys,JR XG8,Tags Mini XBus Dmss//FAA# FA3NYC9TAP

PM  EMAIL  GALLERY  Attn:RR  Quote
06-10-2014 12:28 PM  3 years agoPost 6
dkshema

rrMaster

Cedar Rapids, IA

My Posts: All  Forum  Topic

The AR7000 is a DSM2 receiver, not a flybarless controller. CCPM has nothing to do with this. Arming an ESC would affect only the throttle channel.

If you bind your TX to the AR7000 the servos should move when you move the control sticks. This is basic transmitter/receiver operation that has gone awry.

If you are on a metallic table or benchtop, separate the transmitter from the RX by a few feet.

Is the satellite plugged in and does its LED light up and stay on?

-----
Dave

* Making the World Better -- One Helicopter at a time! *

Team Heliproz

PM  EMAIL  GALLERY  Attn:RR  Quote
06-10-2014 02:18 PM  3 years agoPost 7
tomtek

rrApprentice

ga

My Posts: All  Forum  Topic

Yes, the transmitter is bound to the ar7000. The light on the ar7000 and the satellite are steady. No servo movements with any stick movements. Servos getting power because I can hear them.

PM  EMAIL  GALLERY  Attn:RR  Quote
06-11-2014 07:48 AM  3 years agoPost 8
Roger Salmon

rrNovice

Prenton UK

My Posts: All  Forum  Topic

I had an AR7000 that did the same with a DX8. I concluded that it had early firmware and was incompatible with the transmitter. It worked fine with a DX7.

Logo 550SX Vortex, Logo 600SE 5 blade in a Hughes 500e with Vortex, JR E550 3 blade HC3SX

PM  EMAIL  GALLERY  Attn:RR  Quote
06-11-2014 01:04 PM  3 years agoPost 9
dkshema

rrMaster

Cedar Rapids, IA

My Posts: All  Forum  Topic

What you have should work. The DX6i has been out quite awhile and you can't be the only person on the face of the earth who has bound one to an AR7000, especially since the AR7000 was the workhorse of the Spektrum receiver line for quite awhile.

This one sounds like something the Horizon folk will have to help sort out. Give them a call and see what's up.

-----
Dave

* Making the World Better -- One Helicopter at a time! *

Team Heliproz

PM  EMAIL  GALLERY  Attn:RR  Quote
06-11-2014 10:05 PM  3 years agoPost 10
Stephen Born

rrElite Veteran

USA

My Posts: All  Forum  Topic

tomtek,

What is the history of this AR7000? New/Used? Have you personally used this before?

If this is used and you have never used it before, there might just be an issue with the product.

As Dave indicated, call Horizon Hobby (1.800.338.4639) for free troubleshooting.

PM  EMAIL  Attn:RR  Quote
06-11-2014 11:17 PM  3 years agoPost 11
basmntdweller

rrKey Veteran

Indianapolis IN

My Posts: All  Forum  Topic

This may be dumb, but you aren't plugging in tail servos are you? Tails use different frame rate and will not work straight from rx.
Grab some other servos, maybe non digitals and see if they work.

Matt


Stupid people have no idea how stupid they are!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
06-14-2014 10:00 AM  3 years agoPost 12
tomtek

rrApprentice

ga

My Posts: All  Forum  Topic

Found the problem. Receiver went bad. Thank you for the replies.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1506 views POST REPLY
HelicopterMain Discussion › 6xi binds with ar7000 but servos do not operate
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Tuesday, May 22 - 9:10 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online