RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 1265 views POST REPLY
HelicopterRadio - Spektrum DSM › Spektrum trainer setup
06-05-2014 08:33 PM  3 years agoPost 1
rcflyerheli

rrKey Veteran

Granbury, TX USA

My Posts: All  Forum  Topic

Help!!!! I thought I understand trainer setups, but apparently I don’t. I need some help on trying to set up a buddy box for a friend’s DX18 so I can fly it with my DX18 or DX9. His TX is on mode 2 and I fly on mode 1, so without being able to use the trainer system, I can’t fly his heli.

The problem that I get is that when using the trainer cord with his TX set up as “Programmable Master” or “Pilot Link Master”, I get different outputs on the master TX monitor page when it has trainer button engaged. These differences drive the 3GX/APS controller nuts when trainer is engaged.

I have tried everything from setting up a new model in Acro, or Heli and leaving everything to default, to setting up a new model in Heli and manually setting the slave programming to the exact same values on everything as is the master, to setting up a new model and doing a file copy for the model. In every case, the output is the same. If I look at each TX’s monitor page with the trainer cord connected but not having the trainer button engaged, the monitor values are identical between the two transmitters, but then when I engage the trainer button, the master TX values change.

I’ve talked with HH at length on this issue, and their response was the trainer cord was bad, so they sent me a new one, but I get the exact same response on the operation.

I have tried setting up my DX9 as a master and using the buddy cord to use my DX18 as the slave and vice versa, and I get the same results. HOWEVER, when I use the wireless buddy box function on my DX9 as master and bind it to my DX18 slave, I do get identical values. I just don’t want to have to go through the entire DIR setup on the 3GX to use my DX9 to fly it. I thought that is what the trainer function was all about. Also, according to the manual on the DX18 the inhibit setting doesn’t really inhibit the trainer function, but rather just makes it necessary to set up both transmitters with identical programming, but in real life, inhibit does as Webster indicates it should and inhibits the trainer function.

If someone has ideas or has gone through this process, please let me know.

Goblin 700, Trex 700DFC, Gaui X7, Logo 690SX, Logo 600SX; Trex 470 Trex 500
Amain Team Rep

PM  EMAIL  GALLERY  Attn:RR  Quote
06-06-2014 01:01 AM  3 years agoPost 2
rcflyerheli

rrKey Veteran

Granbury, TX USA

My Posts: All  Forum  Topic

Problem not solved, but at least we have at least duplicated the problem at Horizon. They are relaying this up to Spektrum and will get back with me when Spektrum does their thing.

It's not helping me right now, unfortunately, but at least I do know it's not something I am setting up wrong.

This issue doesn't arise when I use my DX9 as the master, (and presumably with the DX18 V2 with wireless trainer available) but only when a corded buddy system is used. With the wireless, everything transfers normally and works as it should.

Goblin 700, Trex 700DFC, Gaui X7, Logo 690SX, Logo 600SX; Trex 470 Trex 500
Amain Team Rep

PM  EMAIL  GALLERY  Attn:RR  Quote
06-06-2014 01:44 AM  3 years agoPost 3
aerocal

rrApprentice

Central California

My Posts: All  Forum  Topic

I was watching your issue on the other forum as well.Ill reply there for now. Im thinking you may not have an actual problem but are seeing
normal minor differences between Master and Slave that need to be trimmed out.

PM  EMAIL  GALLERY  Attn:RR  Quote
06-06-2014 01:52 AM  3 years agoPost 4
rcflyerheli

rrKey Veteran

Granbury, TX USA

My Posts: All  Forum  Topic

Thanks, I saw that and replied to your post. HH thinks there is an internal issue with the design, as they were able to see the same thing. They are going to get with Spektrum.

Goblin 700, Trex 700DFC, Gaui X7, Logo 690SX, Logo 600SX; Trex 470 Trex 500
Amain Team Rep

PM  EMAIL  GALLERY  Attn:RR  Quote
06-06-2014 03:24 AM  3 years agoPost 5
aerocal

rrApprentice

Central California

My Posts: All  Forum  Topic

As I posted in the other place also I think maybe you simply need to trim the Slave to the Master. This is common.Rarely does the signal come over exactly the same from the Slave and produce the same numbers on the Master.Its only a couple clicks of trim on the Slave to match them.
When you use WLT(wireless trainer) this isnt generally an issue and so far all I have setup as wireless do not need trim to match them.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1265 views POST REPLY
HelicopterRadio - Spektrum DSM › Spektrum trainer setup
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, May 22 - 10:53 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online