RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 854 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Electric Battery-Charger-pSupply
› PowerLab 8 pack removed "Under current" error
02-23-2014 07:44 PM  3 years agoPost 1
AA simon

rrApprentice

barcelos, portugal

My Posts: All  Forum  Topic

hi

i have a new charger PowerLab 8 v2 and when i try to charge i keep getting this error pack removed "Under current" error.

i have tryed checking all the conections and differnt batterys but it still happens.

this only happens when the battery is almost full, i can charge 1 pack at 1 amp or 3 at 6 amps (or any other conbination)and it will get the packs to over 90% and then the error will occur at any time.
any ideas?

Simon Ribeiro

PM  EMAIL  GALLERY  Attn:RR  Quote
02-23-2014 09:36 PM  3 years agoPost 2
rexxigpilot

rrProfessor

Florida

My Posts: All  Forum  Topic

Get a better power supply.

PM  EMAIL  GALLERY  Attn:RR  Quote
02-23-2014 10:26 PM  3 years agoPost 3
Gregor99

rrElite Veteran

Western Wa

My Posts: All  Forum  Topic

That error usually occurs due to power supply or connection issues. If you can test with another power supply, do so. It can also be caused be a bad connection to the power supply. Poor soldering connections between supplies, or conenctors. Or the use of a connector between the charger and the supply which is not suitable for the application. For example use a 4mm banana.

Revolectrix Beta Team

PM  EMAIL  GALLERY  Attn:RR  Quote
02-23-2014 11:17 PM  3 years agoPost 4
AA simon

rrApprentice

barcelos, portugal

My Posts: All  Forum  Topic

thanks, i will try with a diferente power supply and report back,

i thought if the power supply can cope with high loads while the charger is ramping up to full charge rate then how can it be a problem when the charger is ramping down?

Simon Ribeiro

PM  EMAIL  GALLERY  Attn:RR  Quote
02-24-2014 08:50 PM  3 years agoPost 5
AA simon

rrApprentice

barcelos, portugal

My Posts: All  Forum  Topic

Thanks for your help

it does seem that my power supply was not good, i had been using a old atx power supply i had converted for rc use and it works fine with my other chargers.

today i used a hewlett packard DPS 600PB server power supply i had previously bought but not got around to converting,well needless to say it works perfect and no more errors from charger.

so a simple solution, i would never of thought of, because the error said pack removed i was thinking charger onwards never considerd it could be the power supply.

thanks again !

Simon Ribeiro

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 854 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Electric Battery-Charger-pSupply
› PowerLab 8 pack removed "Under current" error
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, October 17 - 12:20 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online