RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 619 views
Helicopter
e-
Align
T-REX 700 › Trex 700E with 3G issues
02-22-2014 02:07 PM  3 years agoPost 1
Woody67

rrApprentice

Powell River BC Canada

My Posts: All  Forum  Topic

Hi, I have been flying my 700e for some time - stock setup, and have been mostly happy with it. I recently upgraded my 3g from 2.1 to 3.0. I upgraded to hopefully fix a small tail wander issue. After 3.0, the tail was solid, but the heli shudders on punch-outs. I turned the gain down, which didn't help. What did help somewhat was increasing the headspeed. I usually like to fly the big bird around 1700, but cant any longer until i get this fixed. Any 3g Guru's around with some good advice?

Help is appreciated,

Woody67

PM  EMAIL  GALLERY  Attn:RR  Quote
03-01-2014 05:00 PM  3 years agoPost 2
Woody67

rrApprentice

Powell River BC Canada

My Posts: All  Forum  Topic

Thanks for all the suggestions guys...I have decided to soak the 3g unit in miller high life, and see if I can dull down the response a tad.....LOL

PM  EMAIL  GALLERY  Attn:RR  Quote
03-01-2014 09:52 PM  3 years agoPost 3
wc_wickedclown (RIP)

rrProfessor

long beach calif

My Posts: All  Forum  Topic

Woody67
Thanks for all the suggestions guys...I have decided to soak the 3g unit in miller high life, and see if I can dull down the response a tad.....LOL
i think the reason no one uses the 3gx is because setup is complicated

Insha Allah made in america

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
03-01-2014 10:42 PM  3 years agoPost 4
dkshema

rrMaster

Cedar Rapids, IA

My Posts: All  Forum  Topic

Setup is dirt simple. So easy a caveman could do it.

Was this a 3G system (two pieces, sensor and separate electronics) or was it the newer 3GX unit?

You should have at least upgraded to V3.1 software.

I hadn't realized you'd even posted here with a problem until just now. Had I seen your post earlier, I would have replied then.

-----
Dave

* Making the World Better -- One Helicopter at a time! *

Team Heliproz

PM  EMAIL  GALLERY  Attn:RR  Quote
03-02-2014 12:35 AM  3 years agoPost 5
Woody67

rrApprentice

Powell River BC Canada

My Posts: All  Forum  Topic

NP, I have the align 3g unit, not the 3gx. It is updated to 3.0. I just test flew it and fixed the problem. I had my govenor gain set too high in the castle speed control, causing a shudder on punch outs... It's perfect now...!!

cheers,

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 619 views
Helicopter
e-
Align
T-REX 700 › Trex 700E with 3G issues
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, December 12 - 12:19 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online