RunRyder RC
 6  Topic Subscribe
WATCH
 1 page 798 views POST REPLY
12-30-2013 10:11 PM  4 years agoPost 1
Toad

rrApprentice

Sandy, Utah

My Posts: All  Forum  Topic

I just bought a used heli from here. I have not flown a heli since the "fury" days and fly-bars. Wow things have changed. Anyway the heli came with the 750 ver 1.1
My question is; Will the 1.31 update work or should I try to find the 1.2 version first? then go to 1.31?
A bit confused here with this stuff.

Thank you in advance.

*****

PM  EMAIL  GALLERY  Attn:RR  Quote
12-30-2013 10:44 PM  4 years agoPost 2
dchekas

rrKey Veteran

Farmington, CT

My Posts: All  Forum  Topic

You can update directly to 1.31. I would suggest doing so, as 1.31 offers many refinements to the control loop to improve the feel of the Gyro.

Team Align, Team Futaba, Team Byron Fuels, Team Thunder Power

PM  EMAIL  GALLERY  Attn:RR  Quote
12-31-2013 01:16 AM  4 years agoPost 3
kym

rrApprentice

Provo Utah

My Posts: All  Forum  Topic

If you need help PM me

https://facebook.com/UtahHeli

PM  EMAIL  GALLERY  Attn:RR  Quote
12-31-2013 02:33 AM  4 years agoPost 4
Kevin Dalrymple

rrKey Veteran

Indianapolis

My Posts: All  Forum  Topic

go right to 1.31. it flies better than 1.2.

PM  EMAIL  GALLERY  Attn:RR  Quote
01-07-2014 03:26 AM  4 years agoPost 5
1tonv

rrApprentice

Pontiac, michigan. U.S.A.

My Posts: All  Forum  Topic

also much easy to setup as most default setting on 1.31 fly great

PM  EMAIL  GALLERY  Attn:RR  Quote
01-07-2014 01:35 PM  4 years agoPost 6
ttrip06

rrApprentice

Central Pa

My Posts: All  Forum  Topic

1.31. is much better, make sure you read the revised directions because the setup procedure is different.

Tim Tripoli

Team Futaba, Rail Blades
Team Crash
ProggressiveRC

PM  EMAIL  GALLERY  Attn:RR  Quote
01-07-2014 02:19 PM  4 years agoPost 7
Ace Dude

rrProfessor

USA

My Posts: All  Forum  Topic

PM  EMAIL  GALLERY  Attn:RR  Quote
01-07-2014 08:19 PM  4 years agoPost 8
jschenck

rrProfessor

La Vista, NE.

My Posts: All  Forum  Topic

I have updated directly from 1.1 to 1.31, no problem. It overwrites whatever is in the unit anyway so it doesn't really matter what code level is in there now.

Be sure to go right in and change the OLED brightness back down so you don't burn out the display especially if you are using a 2S LiPo. I've had two unit's get the vertical line of pixels go all white, same spot too. I think this might be due to the display being overworked when it's set to full bright mode and running on higher voltage.

PM  EMAIL  GALLERY  Attn:RR  Quote
01-07-2014 11:25 PM  4 years agoPost 9
poerQwa

rrVeteran

Rotterdam, The Netherlands

My Posts: All  Forum  Topic

@jschenk
Not sure if the 2S setup has got something to do with it.
Already sent 2 units in with the same issue you describe and they were just running 6V.
But will check the settings on the brightness though.

grtz.

Marc

PM  EMAIL  GALLERY  Attn:RR  Quote
01-08-2014 04:12 AM  4 years agoPost 10
Toad

rrApprentice

Sandy, Utah

My Posts: All  Forum  Topic

Thank you everyone for your help. I have purchased the usb tool and another 750. I am very excited to get them going.

*****

PM  EMAIL  GALLERY  Attn:RR  Quote
01-09-2014 09:09 PM  4 years agoPost 11
utahbob

rrVeteran

St. George Utah

My Posts: All  Forum  Topic

Hey!
Alright Mel! good to hear your'e gonna be back stirrin the sticks again! come down and fly with us sometime--we got a nice spot south of town!--Bob

I do a great decending funnel!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 798 views POST REPLY
 Print TOPIC  Make Suggestion 

 6  Topic Subscribe

Sunday, May 27 - 12:43 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online