RunRyder RC
 5  Topic Subscribe
WATCH
 1 page 425 views
Scorpion Power Scorpion Power
HelicopterMain Discussion › raptor 90 se tail twitch problem
12-16-2013 09:02 AM  3 years agoPost 1
myjane

rrApprentice

new zealand

My Posts: All  Forum  Topic

hi i have tryed everything with this tail , checked all the bearings , the shaft ,all meshing ,transmiter settings , every thing except the new servo savox 1290 ,and the align 780 , my mates all have added there experence and it still throbs backward and forth a bit its not gain settings tryed them all , we knoticed the servo hunts when on hover and the tail wags an inch because of you can see the servo hunting backward and forth a bit all the rod linkages are smooth and free , anybody had the same please tell

PM  EMAIL  GALLERY  Attn:RR  Quote
12-16-2013 10:03 AM  3 years agoPost 2
icanfly

rrElite Veteran

ontario

My Posts: All  Forum  Topic

is it possible the board in the gyro is moving around inside the case a bit?

PM  EMAIL  GALLERY  Attn:RR  Quote
12-16-2013 12:56 PM  3 years agoPost 3
stargazerww

rrApprentice

parkside, pa.

My Posts: All  Forum  Topic

possibly missing teeth on the tail belt ?

make sure you have the trim tab on you radio set to center [no trim at all]

PM  EMAIL  Attn:RR  Quote
12-16-2013 01:09 PM  3 years agoPost 4
PJRono

rrKey Veteran

Minnesota, Ya!

My Posts: All  Forum  Topic

Are you using the carbon boom?

If you skip me I can't play!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-16-2013 01:53 PM  3 years agoPost 5
jason46

rrVeteran

MI

My Posts: All  Forum  Topic

I had a similar issue with a 50 after replacing/swapping many things and checking shaft straightness turned out a rich carb was the cause.

We made up some rules can we have your moneys now.

PM  EMAIL  GALLERY  Attn:RR  Quote
12-16-2013 01:54 PM  3 years agoPost 6
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

Align GP780 is your problem! They are very sensitive! It maybe easier to get a used GP750 as they are much better.

Try different mounting tape and add a metal plate, you want soft pad, metal plate, thin pad, gyro in that order and possibly lightly strap down with a velcro strap.

If it is vibration and it probably is the first thing is to look at engine tuning then look at balancing the engine fan.

Also check boom supports are tight.

If all this fails try adding some delay in the 780.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-16-2013 02:06 PM  3 years agoPost 7
reddragon

rrElite Veteran

Brooklyn, N.Y.

My Posts: All  Forum  Topic

possibly missing teeth on the tail belt ?
No tail belt. Shaft driven.

Wayne - Fly it like you stole it! You're in good hands with Runryder!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-16-2013 02:53 PM  3 years agoPost 8
jwatts007

rrNovice

England

My Posts: All  Forum  Topic

try pulling the boom out of the holder 1/8th of an inch...the T/tube could have a wip in it....

PM  EMAIL  Attn:RR  Quote
12-17-2013 10:20 PM  3 years agoPost 9
PJRono

rrKey Veteran

Minnesota, Ya!

My Posts: All  Forum  Topic

I've had problems with the stock carbom boon, but since you're not running that I would check the gyro.

If you skip me I can't play!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-17-2013 10:36 PM  3 years agoPost 10
Jeff polisena

rrElite Veteran

westpalmbeachflorida​usa

My Posts: All  Forum  Topic

Motor tuning or one way . Also backlash in servo gears . Your getting rebound from gyro caused from inconsistent tail rpm

I stole it ,flew it and gave it back ;)

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 425 views
Scorpion Power Scorpion Power
HelicopterMain Discussion › raptor 90 se tail twitch problem
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Saturday, November 18 - 11:31 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online