RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 350 views POST REPLY
Scorpion Power Scorpion Power
01-26-2013 02:51 PM  4 years agoPost 1
OLROY

rrKey Veteran

Wichita Ks

My Posts: All  Forum  Topic

I have a voltz 3s 2500mah That I've been using since Nov and now it's showing 11v so I've taken out of 11X and battery only reads 1 cell on my pl8 v2???! I used a balance checker it shows all 3cells
3.69 3.68 3.64

So it's low but I can only charge this through my pl8 using balance board as my TP820 won't charge using balance board only

Any idea on only reading one cell on this charger ?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-26-2013 03:31 PM  4 years agoPost 2
eddiscus

rrElite Veteran

Dumont, NJ-USA

My Posts: All  Forum  Topic

Check the wiring config of your balance connector and the config of your charger. Are you using an FMA balance board or an XH/EH board?

Reference page 61 and 67 of the manual.

http://www.progressiverc.com/media/...08%20Manual.pdf

Logo Xxtreme 800
Logo 700
Citizen 142
Synergy 766
TDR 2

PM  EMAIL  GALLERY  Attn:RR  Quote
01-26-2013 04:05 PM  4 years agoPost 3
OLROY

rrKey Veteran

Wichita Ks

My Posts: All  Forum  Topic

My charger is at work so can't look until later tonight but it is the stock one that came with it. The last time I charged this in Nov I remember using I think accurate setting and worked. Thanks for the link I'll double check that tonight.

PM  EMAIL  GALLERY  Attn:RR  Quote
01-27-2013 06:21 AM  4 years agoPost 4
OLROY

rrKey Veteran

Wichita Ks

My Posts: All  Forum  Topic

On page 63 it's the bottom one I'm using

The back of board says

PL8 GP/KO ADAPTOR

And I'm using GP side 3s

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 350 views POST REPLY
Scorpion Power Scorpion Power
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, October 16 - 11:19 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online