RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 616 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Align
T-REX 500 › BeastX setting
08-31-2012 07:24 PM  5 years agoPost 1
mirmanchuck

rrApprentice

Venice Fl.

My Posts: All  Forum  Topic

I have a version 3 beastx and having trouble with setup. I was trying to set the pitch boost parameter and the menu stops at H and exits parameters menu. The pitch boost according to the manual is K. My Beastx stops at H. Do I have the wrong version? I checked the version during initial startup and it is V3. Is it because the Z factor in the XYZ version?

SpectraG/3Dmax
Trex600esp BeastX DFC
QAV500G Multirotor

PM  EMAIL  GALLERY  Attn:RR  Quote
08-31-2012 09:28 PM  5 years agoPost 2
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

Is it because the Z factor in the XYZ version?
Eh?!

Anyway if it stops at H its not a version 3.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
09-02-2012 06:31 PM  5 years agoPost 3
Gailvin

rrApprentice

Abbotsford, BC

My Posts: All  Forum  Topic

Are you sure you're in parameter and not set up mode? I think the set up only goes to H, I did this with my first beast.

HK-500 ; Titan 50 SE ; T-600N ; T-700N
40% Yak; F4U; P-47

PM  EMAIL  GALLERY  Attn:RR  Quote
09-02-2012 06:35 PM  5 years agoPost 4
mirmanchuck

rrApprentice

Venice Fl.

My Posts: All  Forum  Topic

Light is blinking instead of solid. That's parameter mode. I think I need to update firmware. Lights on unit indicate V3.

SpectraG/3Dmax
Trex600esp BeastX DFC
QAV500G Multirotor

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 616 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Align
T-REX 500 › BeastX setting
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, October 23 - 3:27 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online