RunRyder RC
 5  Topic Subscribe
WATCH
 1 page 1643 views POST REPLY
Scorpion Power GLOBAL 3D
HelicopterEngines Plugs Mufflers Fuel › YS-60SR,, strange issue
08-04-2012 07:02 PM  4 years agoPost 1
caser

Senior Heliman

deep jungle

My Posts: All  Forum  Topic

Guys, install a new 60 in my Synergy N5C last week, hookt up with the new Hatory 60pipe,,
done around 15 smooth rich hoover flights,,

However anytime if now i want to go idle up or running more then 60% headspeed the engine dies out but when i recover trottle lower it will come back again,,

I tid try out any possible needlesettings,, it looks to me the higher needel do not respons on changes,,

Plug YS,, and running it with Byron fuel 30% master blend.
The thank lines and filter are clean and fine,,

what can it be????????

thanks..

PM  EMAIL  Attn:RR
08-04-2012 07:54 PM  4 years agoPost 2
airdodger

Elite Veteran

Johnston USA

My Posts: All  Forum  Topic

Fifteen tanks just hovering, really? You should reset the needles to factory run settings, use a new plug, make sure you have no pressure leaks, and try again.

Chris

PM  EMAIL  GALLERY  Attn:RR
08-05-2012 12:58 AM  4 years agoPost 3
ch-47c

Elite Veteran

san jose, ca

My Posts: All  Forum  Topic

Are you using a govenor?
Did you change the lower throttle curve points?

PM  EMAIL  GALLERY  Attn:RR
08-05-2012 02:25 AM  4 years agoPost 4
rexxigpilot

rrProfessor

Florida

My Posts: All  Forum  Topic

It has to be either real rich or extremely lean on the high needle. Since it came back after you reduced the throttle, I'm thinking it must be pig rich. Go to factory on the HIGH needle and reduce from there until there is no bogging out.

PM  EMAIL  GALLERY  Attn:RR
08-05-2012 10:46 AM  4 years agoPost 5
caser

Senior Heliman

deep jungle

My Posts: All  Forum  Topic

try all those things,, 100% no leak, change plug, have been over and over back to factory settings,, leanit and rich it,, no way....

no gov,, as it first should runn in nicely,,
it seems to me that there is something blocking the fuel transfer on the high needel,, maybe from production??or the membrane is stackt?

PM  EMAIL  Attn:RR
08-05-2012 03:53 PM  4 years agoPost 6
rexxigpilot

rrProfessor

Florida

My Posts: All  Forum  Topic

You could have something blocking the regulator. Carefully take it apart and check it.

PM  EMAIL  GALLERY  Attn:RR
08-07-2012 03:20 AM  4 years agoPost 7
bobbyra

Senior Heliman

Fort Myers Fl

My Posts: All  Forum  Topic

Mine was running rich at 2 out on mid and high at the factory settings.

PM  EMAIL  GALLERY  Attn:RR
08-12-2012 07:36 AM  4 years agoPost 8
caser

Senior Heliman

deep jungle

My Posts: All  Forum  Topic

Ok Guys, i could make it work finaly, i removed the needles and blow high pressured air thrue the carburator?, hope its the right name in english,,
i guess the Membrane was stuckt somehow,, i could not fine anything else,,

aniway it works now perfect and the engine really has power!!

maybe one hint, i find out that this engine i really sensitive on tuning, Not Difficould but sensitive.

I have mine at 1.4 open and 1,6 at the midrange.
By just change the needles for only 1 or 2 clicks can make it perfect or
even complet not work.
so if you are tuning it, go slowly one by one.
thats what i find out..

thanks for the Hints`!

PM  EMAIL  Attn:RR
08-29-2012 06:43 PM  4 years agoPost 9
Hakulhak

Heliman

Malaysia

My Posts: All  Forum  Topic

Welcome To YS
you will never regret

Thank you

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
09-01-2012 05:01 AM  4 years agoPost 10
MANCHA

Veteran

Cabo San Lucas, Baja- Mexico

My Posts: All  Forum  Topic

Once tuned up it will perform perfect all season; in winter fine tuning will be in order again.

Enjoy.

MANCHA

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 1643 views POST REPLY
ProModeler Scorpion Power
HelicopterEngines Plugs Mufflers Fuel › YS-60SR,, strange issue
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Thursday, June 29 - 4:53 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online