RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 573 views POST REPLY
Helicopter
e-
Electric Motors-Controllers-ESC
Other › Did I get a dud ICE2 HV120?
06-10-2012 11:55 AM  5 years agoPost 1
Individual1

rrApprentice

Florida

My Posts: All  Forum  Topic

Just got three new Castle ICE ESC's from Horizonhobby.

- ICE50
- ICE75
- ICE2 HV120

I connect the ICE50 and the ICE75 to my Castle Link, the little red/green light blinks with happiness and I can see the current settings on my computer screen.

I connect the ICE2 HV120 and the link stays solid red and doesn't read anything.

When I go back and forth to the ICE75, ICE50 and I even have a Phoenix 25.. They all work.

I have had my Castle Link for a while. Maybe the ICE2 120HV needs a newer version? That seems crazy, but it was worth mentioning.

Thoughts?

PM  EMAIL  GALLERY  Attn:RR  Quote
06-10-2012 01:00 PM  5 years agoPost 2
Raydee

rrKey Veteran

Western New York

My Posts: All  Forum  Topic

I posted in the other forum but try connecting your main battery pack.

The Future of Nitro is ELECTRIC

PM  EMAIL  GALLERY  Attn:RR  Quote
06-10-2012 01:40 PM  5 years agoPost 3
Individual1

rrApprentice

Florida

My Posts: All  Forum  Topic

Solved
Right in the manual! I should have read that whole manual! They tried teaching me in the military to never assume. I did not learn my lesson!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 573 views POST REPLY
Helicopter
e-
Electric Motors-Controllers-ESC
Other › Did I get a dud ICE2 HV120?
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Tuesday, May 22 - 5:16 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online