RunRyder RC
 6  Topic Subscribe
WATCH
 1 page 2245 views POST REPLY
HelicopterFuel-Helicopters New or Limited ActivityOutrage › anyone having issues with the volicity N2 kit please post here
01-26-2012 11:06 AM  6 years agoPost 1
cheepstr

rrApprentice

Ferndale WA

My Posts: All  Forum  Topic

OK! here is the deal
I just got my N2 kit on monday and started building it first I noticed the cracks in the canopy and shotty paint job
that was a disapointment first thing!! then started to build the head and found the ball link not finished cant put the tool in it to tighten it!!!!! this really pissed me off now I'm short a ball link. then I thought after that I'd keep building but when I got to the tail rod guides they have screws that tighten them to the boom to my suprise (lol) the screw has no threds also the tail box has a spacer at the verry end well the machining looks like crap witch in turn makes the tail look like crap!
WOW! I thought the 3 month wait was for quality controll?? the bad thing is I've only finished with the head and the tail. stay tooned to see if I have any more issues.
OH yea this is my first outrage and might be the last!
I'll add pictures of canopy later forgot at friends house

PM  EMAIL  GALLERY  Attn:RR  Quote
01-26-2012 12:49 PM  6 years agoPost 2
praztek

rrApprentice

brandon , fl

My Posts: All  Forum  Topic

No issues here, I was actually surprised how well the overall product was , If I were you, would give them a call and get a whole replacement kit.

PM  EMAIL  GALLERY  Attn:RR  Quote
01-27-2012 05:51 AM  6 years agoPost 3
aerosmith

rrApprentice

Mississippi

My Posts: All  Forum  Topic

Sorry for the issues cheepstr. My N2 will be here tomorrow & I'm excited about it. I'd contact the company you bought it from. Hopefully they'll make things right. Being a fresh batch of units, I figure they would expect a few problems. Let us know how it goes...Good luck!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-27-2012 11:05 AM  6 years agoPost 4
cheepstr

rrApprentice

Ferndale WA

My Posts: All  Forum  Topic

issues were fixed
I talked with larry at heli direct and they are sending the parts and should be to me in a cupple days the canopy they dont have in stock but should be soon. glad to hear you guys have had no problems just my luck to get all the issues in my kit lol

PM  EMAIL  GALLERY  Attn:RR  Quote
01-30-2012 06:52 PM  6 years agoPost 5
Triple-D TJ

rrApprentice

Buffalo, New York

My Posts: All  Forum  Topic

The only grip I have with kit is the canopy paint. Looks like hair line cracks & bad masking. I dont really mind though, first big crash will take care of all that!

PM  EMAIL  Attn:RR  Quote
01-31-2012 12:06 AM  6 years agoPost 6
John Krebs

rrVeteran

Pittsburgh, PA

My Posts: All  Forum  Topic

On the left side frame the hole for the elevator bearing and the cutouts for the servo mount were too small. I few seconds with a rat tail file took care of it though.

You have to be very careful with the Loctite around the dog bones that connect the pitch slider to the tail grips. I would recommend putting the Loctite on the tip of a piece of wire or similar and placing it inside the threads on the grip rather than on the threads of the small shouldered screws. I did mine that way using a very tiny anount of Loctite and still had to do one over again because it was binding. I've heard of of couple of other guys that had the same issue. No fault of the kit though. Just very close tolerances.

I used a different spacer under the elevator servo. The spacer in the kit is 9mm high and I only needed 3mm using Torq servos.

I made new canopy stand-offs that use thumb screw becasue I did want to be prying the canopy apart to get it off. Particularly in the front. The only thing I don't like about the kit is that you have to split the frames to get the tank out. But that might turn out to be a non-issue since the tank sits on rubber pads and shouldn't wear through like the Raptor tank does.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-01-2012 12:25 PM  6 years agoPost 7
aerosmith

rrApprentice

Mississippi

My Posts: All  Forum  Topic

John, I noticed you mounted your struts sweeping forward.
I started to...I kept debating about it & just decided to sweep back. It looks good to me either way. I completed my build today but now I'm waiting on a engine and a few other items. All in all I didn't have any issues but there's quiet a bit more to do. I just have the airframe completed. I'm liking this N2 & cant wait for the test flight! BTW. I agree about the fuel tank removal!!! I love the system on my Vibe. Piece of cake & it makes changing fuel lines a breeze.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-01-2012 12:41 PM  6 years agoPost 8
John Krebs

rrVeteran

Pittsburgh, PA

My Posts: All  Forum  Topic

I put them on the they are shown in the instructions. I've seen a lot of guys put them on backwards on Raptors. Backwards would help while building as the heli does want to tip back until you get everything mounted. Dry the heli balances dead level I think I may be a tad tail heavy when I put fuel in it. We'll see.
I just got a set of rail blades for it. Might as well start off with everything brand new.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-01-2012 01:21 PM  6 years agoPost 9
aerosmith

rrApprentice

Mississippi

My Posts: All  Forum  Topic

Good deal. I went by the picture on the first page of the pdf instructions. That reminds me, I ran out of printer ink during my build. I did print 3 or 4 pages before the wife got on our computer. It's just she & I here & we both share this iMac. I guess a paper copy of instructions is un-cool these days. I don't have a problem with pdf files but now days you had better have a computer/printer or know someone that does, ha ha. I did hog our computer due to studying the diagrams & notes.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-04-2012 10:35 PM  6 years agoPost 10
shiver

rrApprentice

Ireland

My Posts: All  Forum  Topic

Started my build today. What a let down this kit is. Radius arms with screws fitted and no heads on them. Swashplate cup with no threads:confusedjust holes). Torque tube gears that are so tight they hardly move.The list goes on. Not gonna bother finishing it. Lesson learned. My first and last Outrage. I actually have to buy parts so i can sell the kit complete.

PM  EMAIL  GALLERY  Attn:RR  Quote
02-04-2012 11:33 PM  6 years agoPost 11
John Krebs

rrVeteran

Pittsburgh, PA

My Posts: All  Forum  Topic

I would go to the helidirect website and click on the "Contact Us" link at the top of the page and enter a trouble ticket. I'll bet they make it right.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-05-2012 05:07 AM  6 years agoPost 12
john.hopkins

rrNovice

FT Pierce, Florida United states

My Posts: All  Forum  Topic

I have about 6 flights on my N2 now. As far as problems with the build, I didnt have any. It was when I went to a Daytona funfly last weekend and went to start my heli for 2nd time. The starter shaft binded up and I actually torqued the hell out of my thumb. Every time I tried to start it the main gear and pinion was turning with the starter. I ended up working on it the whole day rather than flying. I called helidirect on Mon, and talked to Larry and he took care of everything. I got my new parts today and I am good to go. Just so you know it helps if you use a shim in between the pinion and bearing block. Thats what was wrong with mine. It was binding big time. As far as Outrage kits, I have built 4 so far and as long as you take your time and follow the instructions. Your good! I love my Fusion, and my Velo V1 and now my N2.

PM  EMAIL  GALLERY  Attn:RR  Quote
02-06-2012 02:15 PM  6 years agoPost 13
Triple-D TJ

rrApprentice

Buffalo, New York

My Posts: All  Forum  Topic

The only issues I have are the bevel gears on the TT... They are were tight from day 1 and I even replaced them only to find them to mesh even tighter.. Not sure what needs to be done here..

PM  EMAIL  Attn:RR  Quote
02-06-2012 11:33 PM  6 years agoPost 14
John Krebs

rrVeteran

Pittsburgh, PA

My Posts: All  Forum  Topic

My bevel gears were tight and notchy also. A friend of mine that has built a few Veolocites told be to use a screwdriver and carefully pry the rear bevel on the torque tube axis forward and pry the front one rearward. That took care of the problem. He also said to put some Triflow on the gears. That seemed to help also. I'm sure the remaining friction will go away after some flights.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-02-2012 06:33 AM  6 years agoPost 15
Furyflyer2

rrNovice

USA

My Posts: All  Forum  Topic

Zero issues here, went together with no trouble 3rd outrage kit with no issues.

Paul G- Team 3DXhobbies

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
04-03-2012 12:22 PM  6 years agoPost 16
jonathan

rrNovice

italy, rome

My Posts: All  Forum  Topic

Clutch and shaft issues.
Hi guys,

tryed to start my engine the other day but it kept shutting off. I htought it was the engine but dismounted it and checked everything and it is fine (Completely new os 55 HZ-H). I then saw that if i gave immediately half gas it would start fine but anything less it would struggle to rev up and would the slowly shut down (ps i tried all combination of carburations so it isnt that), so i think it is the clutch which is kicking in too soon, killing the engine. Anyone have a similar prob? I also had a prob with the starting shaft, it got stuck and wouldnt spin freely so had to dismount it and saw that the fit is too tight within the clutch bell and so sanded it down so it is ok now.

following question. How do you guys find the tail blades given in the kit?

Thanks

Jonathan

PM  EMAIL  GALLERY  Attn:RR  Quote
04-04-2012 03:30 PM  6 years agoPost 17
Triple-D TJ

rrApprentice

Buffalo, New York

My Posts: All  Forum  Topic

I'm not an expert at motor tuning, but in my experience the OS55HZ tuning is fairly easy. With what you describe, sounds to me that is the issue. Not the clutch engaging too soon.

There are three needles for tuning, low - mid - high. I Believe low is your issue (Flat Head Screwdriver required)

I found Low should be set about a 1/4 turn (clockwise I think) from factory set point. This is to lean out the low end as they tend to be rich from original setting.

This should solve your issue, and the easiest place to start.

PM  EMAIL  Attn:RR  Quote
04-14-2012 12:17 PM  6 years agoPost 18
jonathan

rrNovice

italy, rome

My Posts: All  Forum  Topic

Hi Guys
I have a problems of vibration when my rpm goes up to idle up 1. Can't understand what it is, the blades are balanced it's a new heli so no crashes. The only thingi can notice is my main tail drive gear doesn't turn quite flat but moves up and down a bit. I thought it was the gear so I changed. But same prob. So I changed the Oneway sleeve, but same prob. The only thing I can think of is that when you put the gear on the sleeve I have to twist it as it is a v.tight fit and so a bit of the plastic comes off, hence a slightly angled tail gear. Anyone have these vibration prob and gear prob? Thanks guys

PM  EMAIL  GALLERY  Attn:RR  Quote
04-14-2012 07:17 PM  6 years agoPost 19
Hotwings

rrKey Veteran

Florida, West Palm Beach.

My Posts: All  Forum  Topic

no issues with three i have!

Please cancel my clearance, I have the field in sight. Got my RW Turbine Waiver, need lottery!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 2245 views POST REPLY
HelicopterFuel-Helicopters New or Limited ActivityOutrage › anyone having issues with the volicity N2 kit please post here
 Print TOPIC  Make Suggestion 

 6  Topic Subscribe

Saturday, May 26 - 7:41 pm - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online