RunRyder RC
 5  Topic Subscribe
WATCH
 1 page 1220 views
Scorpion Power Scorpion Power
HelicopterFlybarless Rotor Head SystemsBeastX › need help with beast x first time setting u fbl
12-19-2011 04:00 AM  5 years agoPost 1
flyindude

rrNovice

norman,oklahoma

My Posts: All  Forum  Topic

hi i just got my first beast x and im trying to set it up per the manual i got all the lights on it set like it says and iv followed it to a t ,but when i go to take off i get just above half throttle and it starts to lift off then the tail blows out either left or right, my gain is at 75 wich is what it says about f-g iv reset it twice already and still cant get it , is there something iv looked over ??? or am not doing right
heres the setup
ma furion 450
beastx v2
hitec5065 on cyclic
futaba s9257
spektrum ar6110e

any help is greatly appreciated

PM  EMAIL  GALLERY  Attn:RR  Quote
12-20-2011 01:05 AM  5 years agoPost 2
flyindude

rrNovice

norman,oklahoma

My Posts: All  Forum  Topic

guess nobodys had any problems then ...

PM  EMAIL  GALLERY  Attn:RR  Quote
12-20-2011 02:48 AM  5 years agoPost 3
lowanslow

rrNovice

Osceola, IN

My Posts: All  Forum  Topic

Which radio? I had to read that manual 10x before the light bulb when on in my head and I "got it"...

On my dx7 my gain is at like +34

PM  EMAIL  Attn:RR  Quote
12-20-2011 03:01 AM  5 years agoPost 4
flyindude

rrNovice

norman,oklahoma

My Posts: All  Forum  Topic

Sorry I have a dx7 and thanks ill give that a shot just seems backwards for it to be set that low

PM  EMAIL  GALLERY  Attn:RR  Quote
12-20-2011 12:47 PM  5 years agoPost 5
theriddick45

rrVeteran

United States

My Posts: All  Forum  Topic

Did you select the right frequency in the beast unit. Check menu D what servo are you running on the tail?

Suzi Janis 800e & 700e 3blade both w/Ikon

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-20-2011 03:04 PM  5 years agoPost 6
5high

rrNovice

NW Montana

My Posts: All  Forum  Topic

Something that is seldom made clear and I may not be able to explain.

The radio inputs and the control unit have nothing to do with each other. Your inputs on the radio can be correct, however the unit can be backwards to the radio and vise versa.

It sounds as if the tail is backwards to the radio. Simply reversing the servo does not work. Check the direction for the tail in the Beastx and make sure its set up properly. The situation you describe, indicates the two are fighting each other.

You should start your gain on F or G and adjust from there. On the DX7, that will be around 66 or so. Good luck and if I can help, PM me.

I have Beastx on two birds and have set up a friends as a gyro only. The unit works very well and is simple once you get the hang of it.

Life is short, Let it fly!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-21-2011 03:26 AM  5 years agoPost 7
flyindude

rrNovice

norman,oklahoma

My Posts: All  Forum  Topic

Well iv played with the gain an tried it and it still spins out , as for the reverseing I have it so that when I move the nose right the trailing edge of the tail blade is pointing righ like tha manual says and still the same thing

PM  EMAIL  GALLERY  Attn:RR  Quote
12-21-2011 09:01 AM  5 years agoPost 8
meatbomber

rrApprentice

Klatovy, Czech​Republic

My Posts: All  Forum  Topic

Did you fly this heli before? If not are you sure the tail turns the right direction?

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-21-2011 03:59 PM  5 years agoPost 9
nickwap

rrVeteran

Berwick-upon-Tweed,​Northumberland,​England

My Posts: All  Forum  Topic

Th BEAST manual does have some precise instructions as to setting the tail in the correct sense, I would double check that first.
Also
Have you set the Revo mix in the beast correctly? The default setting is correct in most cases.
That is F in the Parameter menu.

The Tail sensor direction is set at F in the Setup Menu, how ever the tail must be set up to work the correct way in the radio first.

The Tail set up pages are 42 - 46 in the V3 Manual , (I assume you are running V3, if not update the Beast to V3 first and re do all the set-up)

Is this with a belt drive? (Sorry not familiar with Furion) Is it set up correctly - i.e. the belt is not reversed.

Also like meatbomber has this heli flown before you fitted the Beast or is it a new build?

Have you set the tail mechanically correctly?

Have you set the end points correctly, Beast E in setup menu.

Have you used sub trim or set trim on the TX inadvertently?
I guess you know NOT to use trims on a FBL system.

Let us know how you get on.

Nick

"Give me another one, this one's broke!"

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 1220 views
Scorpion Power Scorpion Power
HelicopterFlybarless Rotor Head SystemsBeastX › need help with beast x first time setting u fbl
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Wednesday, November 22 - 5:51 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online