RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 2165 views POST REPLY
Scorpion Power Scorpion Power
HelicopterPhotos and Videos › Smacktalk 3D Episode 8 - Piro loops - Problem in Phönix Simulator
12-18-2011 06:13 PM  5 years agoPost 1
Stefan_AS

rrNovice

Esslingen - Germany

My Posts: All  Forum  Topic

Dear all,

I am currently trying to learn piro loops as shown by bert (great episode, like all the previous episodes). I am praticing in the Phönix RC simulator.

Problem is: No matter how much speed I am picking up, once i start pirouteeting and do the "back, back, back" practice, the Heli never
does even a half loop, it looses speed at about 1/4th.

No problem doing normal loops, outside loops, backward, outside backward and even standing 8 - all with even less speed.

Does anybody have an idea what I am dooning wrong?

Thank you and best regards
Stefan

PM  EMAIL  Attn:RR
01-04-2012 07:10 PM  5 years agoPost 2
Seth Killian

rrNovice

mesa, arizona, usa

My Posts: All  Forum  Topic

What do you mean it loses speed? or do you mean the tail doesnt have enough power to muscle through it? can you post a video of what happens, i'd be glad to help you.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
02-08-2012 03:51 PM  5 years agoPost 3
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

Use less cyclic input and more collective.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
WATCH
 1 page 2165 views POST REPLY
Scorpion Power Scorpion Power
HelicopterPhotos and Videos › Smacktalk 3D Episode 8 - Piro loops - Problem in Phönix Simulator
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, September 26 - 7:13 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online