RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 1567 views
Scorpion Power Scorpion Power
12-12-2011 08:44 AM  5 years agoPost 1
Friday Fly Day

rrNovice

Louisiana

My Posts: All  Forum  Topic

Hey guys I've tried everything with my 3Gx. I'm using a futaba 6106 fasst receiver with a 7c. I have seen all the diagrams on how to wire the plugs from my 3Gx to my receiver and I just cannot get any power to the 3gx or receiver, nothing, nada. I've tried every combination of plugging them in but still nothing. I'm baffled and frankly I'm about to give up. Any advice would be nice. Thanks guys

PM  EMAIL  GALLERY  Attn:RR  Quote
12-12-2011 08:54 AM  5 years agoPost 2
jsenicka

rrProfessor

Eagle River, WI

My Posts: All  Forum  Topic

can you post a nice clean close up shot of your wiring, including the power plug?

Jim Senicka
Team Manager, GrandRC Flight Team

PM  EMAIL  GALLERY  Attn:RR  Quote
12-12-2011 10:47 PM  5 years agoPost 3
Friday Fly Day

rrNovice

Louisiana

My Posts: All  Forum  Topic

Yes I'll post a pic in a sec. But I'm confused do you have to hve a second battery plugged into the 3GX when using futaba?

PM  EMAIL  GALLERY  Attn:RR  Quote
12-13-2011 01:46 PM  5 years agoPost 4
dcbusdriver

rrApprentice

Stephens City,VA ​-USA

My Posts: All  Forum  Topic

It sounds like you are not getting any power into the receiver itself. Check the power going into the receiver is hooked up with correct polarity. If it's not getting power then neither will the 3g unit. Double check the polarity of the leads coming from the 3g unit into the receiver or you will not get any power from the receiver.

beating the air into submission...........cool!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-13-2011 04:48 PM  5 years agoPost 5
jsenicka

rrProfessor

Eagle River, WI

My Posts: All  Forum  Topic

The signal leads that connect 3GX to receiver are not carrying power. You will need a power lead between power source and 3GX

Jim Senicka
Team Manager, GrandRC Flight Team

PM  EMAIL  GALLERY  Attn:RR  Quote
12-15-2011 11:32 PM  5 years agoPost 6
basmntdweller

rrKey Veteran

Indianapolis IN

My Posts: All  Forum  Topic

There were also some of the early manuals came out that had the power connections labeled wrong. The power cable from the RX to the 3GX unit may need to be plugged into the 3GX backwards from the way the manual shows it. I set up a friends 550 that was this way but my newer 600EFL Pro was correct in the manual.

Matt


Stupid people have no idea how stupid they are!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
12-20-2011 07:31 PM  5 years agoPost 7
Stephen Born

rrElite Veteran

USA

My Posts: All  Forum  Topic

Did you use a bind plug in the receiver? 3GX? The reason I ask, I am using the 3GX with 2 DSMX satellites. I connected the 1900mAh to the bec to the 3GX. Tried to turn on the FBL unit and it did not work. No power at all. Put in bind plug into the 3GX, bound it, and it came alive. BUT, you have to pull the bind plug out after this step.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 1567 views
Scorpion Power Scorpion Power
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Saturday, November 18 - 4:32 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online