RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 547 views POST REPLY
Helicopter
e-
Mikado
Logo 600 › Carbon Fiber Logo 600 load question
10-30-2011 08:55 AM  6 years agoPost 1
jaggies

rrNovice

Silicon Valley, CA

My Posts: All  Forum  Topic

I recently picked up a used CF Logo 600. I noticed there's no C clamp at the end of the shaft unlike my Logo 600 3D. In fact, the shaft only extends halfway through the lower bearing block, so there's no place to put one because of this.

This implies that all of the load (in a vertical climb-out, for example) is carried by the pin in the tail rotor drive pully.

That seems like a lot of load to be going through a plastic part. Does it hold or is there something I'm missing about how the load is distributed in this thing?

At a minimum, I would expect the plastic part to deform over time, resulting in vertical play in the main shaft.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-30-2011 01:32 PM  6 years agoPost 2
wrongler

rrProfessor

Brewerton, New York

My Posts: All  Forum  Topic

It has not been a issue with any of my Logo's as of yet. Some are over a year old and flown quite often.
There is a aluminum belt pulley available at ReadyHeli, That may give you more piece of mind.

Bill Whittaker

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 547 views POST REPLY
Helicopter
e-
Mikado
Logo 600 › Carbon Fiber Logo 600 load question
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Saturday, April 21 - 12:51 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online