RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 589 views POST REPLY
Helicopter
e-
Electric Battery-Charger-pSupply
› Explain This One Please ?????
08-08-2011 01:30 AM  6 years agoPost 1
Brett

rrVeteran

Chicago Burbs

My Posts: All  Forum  Topic

So today I put a pack in that I know I charged last night. Its a 6s 4000Mah pack. The motor would not start, never got the three tones from the ESC. Put a new pack in and it started fine, flew for about 10 minutes on an identical 4000mah pack, then flew again on a 3600 pack. Took the pack that would not starthome attempted to charge it and after 3-5 seconds it says done. Im using the icharger with a more than ample power supply. Not real experienced with these electrics so a bit baffled.

Help, suggestions thoughts ?

If you can't do it right Don't do it!

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2011 02:04 AM  6 years agoPost 2
kcordell

rrElite Veteran

O Fallon, MO

My Posts: All  Forum  Topic

Do you have a lipo checker? What voltage readings are you getting on each of the 6 cells thru the balance tab?

Team Futaba, Team Synergy/Rail, Team Scorpion, Team Castle Creations, YS Engines, VelTye

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2011 02:08 AM  6 years agoPost 3
Brett

rrVeteran

Chicago Burbs

My Posts: All  Forum  Topic

Now Its All Dead
This problem just got stupider. I wanted to know why this happened today so I checked the battery packs voltage and its like 25.18 so I loosened the motors screws slid it back, put the battery in and the gyro and servos came on, pushed the stick up a small tad and the motor started to spin ( i kept it very low night even a full turn just a creeping crawl and then boom its all black, no gyro lit up no servo chatter just total black out. Put another battery in and its still dead. What up with this ?

Thanks

If you can't do it right Don't do it!

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2011 04:44 AM  6 years agoPost 4
flyride

rrKey Veteran

Salt Lake City UT

My Posts: All  Forum  Topic

What esc do you have? It sounds like it just crapped out on you.

and the blonde said "RECTUM, Hell damn near killed em!!"

PM  EMAIL  GALLERY  Attn:RR  Quote
08-08-2011 01:43 PM  6 years agoPost 5
Brett

rrVeteran

Chicago Burbs

My Posts: All  Forum  Topic

Align RCE-BL70G

If you can't do it right Don't do it!

PM  EMAIL  GALLERY  Attn:RR  Quote
08-09-2011 12:13 AM  6 years agoPost 6
flyride

rrKey Veteran

Salt Lake City UT

My Posts: All  Forum  Topic

I had an align esc crap out on me on the first spool up a little pop then that is all. I would pull it apart and see if it is burnt anywhere or see if there is a loose wire or something. I never went back to the align esc after that.

and the blonde said "RECTUM, Hell damn near killed em!!"

PM  EMAIL  GALLERY  Attn:RR  Quote
08-09-2011 12:59 PM  6 years agoPost 7
Brett

rrVeteran

Chicago Burbs

My Posts: All  Forum  Topic

It smells cooked. All I can think of is that the blades were folded in and on the blade holder, perhaps the servos caused an over current. I was not thinking about that at the time.

If you can't do it right Don't do it!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 589 views POST REPLY
Helicopter
e-
Electric Battery-Charger-pSupply
› Explain This One Please ?????
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Tuesday, April 24 - 5:57 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online