RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 629 views POST REPLY
Helicopter
e-
Electric General Discussion
› Temp after flight.
08-06-2011 07:40 PM  6 years agoPost 1
seldred

rrVeteran

Newnan, GA

My Posts: All  Forum  Topic

Just had the maiden flight on my rex 700e. I hovered it for all of 2-3 min MAX. It did not have the canopy on it and was never put into idle up. I landed and noticed that my esc and motor were hotter than what I would expect them to be. My set-up is as follows:

BLS 451 cyclic, bls 251 tail, jive 80hv esc, stock 700mx motor, two voltz 6S 5100 45C lipos in series.

I don't have a temp gun to tell you exactly what the temp is, but the motor was too hot to keep my hand on it and the esc felt very warm, but I could squeeze it and hold on with no problem. This is my first 12S setup and first 90e, but have other electric helis including a 10s furion 6 with the same esc.

Is it to be expected to have a hot motor/ esc with this set up?

PM  EMAIL  GALLERY  Attn:RR  Quote
08-09-2011 12:20 AM  6 years agoPost 2
seldred

rrVeteran

Newnan, GA

My Posts: All  Forum  Topic

Have flown the heli twice since the initial hover. My third flight on it I put it through its paces and threw it around a little. Upon landing the esc felt normal and motor was cooler than it was on the first flight. I carefully looked at the motor and notices some streaks on the top and bottom where it looked like a liquid had spun out. I think the higher than normal temp on the first flight was some excess oil burning off from the factory. Also, that would explain the smell I noticed when I went up to it the first time.

Very happy with this set up and this heli!!! Gotta love the sound of those 690 blades biting the air!!

PM  EMAIL  GALLERY  Attn:RR  Quote
08-12-2011 02:38 PM  6 years agoPost 3
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

My Jive 80HV also heats up my 700MX motor more than the CC80HV does. The motor may run hotter just hovering as they don't like to be run on low throttle, the gearing on the 700E is quite steep. The streaks you saw was probably the grease in the bearings melting and escaping. Run KSA mode, it seems to help.

60% of the time, it works every time!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 629 views POST REPLY
Helicopter
e-
Electric General Discussion
› Temp after flight.
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Friday, January 19 - 7:16 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online