RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 827 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Castle Electric Components
› Castle Link Update Issues
04-09-2011 04:44 AM  6 years agoPost 1
2tall

rrVeteran

Crystal Lake, Illinois, USA

My Posts: All  Forum  Topic

I was running Castle Link version 3.29 without issue until this evening when I accepted a pop-up invitation to upgrade to a newer version (3.30). I went through the download/install process following the detailed instructions for Windows 7 users. The process completed without a hitch and the new Castle icons appeared on my desktop. When I attempt to launch the full program or the viewer Windows instantly responds "Castle Link has stopped running. Windows is searching for a solution for this problem..." Then nothing. I have removed and re-installed the program two more times with the same result. I have sent an email to Castle support. Anyone have a similar experience or know of a fix? My version 3.29 is gone, and I can't find a download for that previous version on Castle's site.

Thanks

"Pay attention...lest the ground rise up and smite thee."

PM  EMAIL  GALLERY  Attn:RR
04-09-2011 01:17 PM  6 years agoPost 2
RS Rogers

rrNovice

Clyde NC

My Posts: All  Forum  Topic

PM  EMAIL  GALLERY  Attn:RR
04-09-2011 06:27 PM  6 years agoPost 3
2tall

rrVeteran

Crystal Lake, Illinois, USA

My Posts: All  Forum  Topic

Thanks for the link. That download works perfectly on my confuser. If Castle sends me a solution for their latest version running in a 64 Bit Windows 7 environment I'll post it here.

Thanks again.

"Pay attention...lest the ground rise up and smite thee."

PM  EMAIL  GALLERY  Attn:RR
04-09-2011 09:19 PM  6 years agoPost 4
FloridaHeli

rrVeteran

jacksonville, florida

My Posts: All  Forum  Topic

RS Rogers

I'm in the process of buying a Castle Creations Phoenix Ice 100 ESC. My PC uses Windows XP 5.1.2600 Service Pack 3 Build 2600.

Will the link you referenced work on my PC?

thanks,

This hobby is WAY too expensive!!

PM  EMAIL  GALLERY  Attn:RR
04-09-2011 09:54 PM  6 years agoPost 5
RS Rogers

rrNovice

Clyde NC

My Posts: All  Forum  Topic

Yes
The last 2 releases 3.00 & 3.00.1 have had a bug & this will just take you back to the last 3.29 release that works perfectly fine.

Steve

PM  EMAIL  GALLERY  Attn:RR
WATCH
 1 page 827 views POST REPLY
Scorpion Power Scorpion Power
Helicopter
e-
Castle Electric Components
› Castle Link Update Issues
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Wednesday, September 20 - 3:41 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online